Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: scriptler-plugin
    • Labels:
    • Environment:
      Jenkins 1.452
      Red Hat Enterprise Linux Server release 6.2 (Santiago)
      Linux <HOSTNAME> 2.6.32-220.4.1.el6.x86_64 #1 SMP Thu Jan 19 14:50:54 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
    • Similar Issues:

      Description

      org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:824)
      at jenkins.model.Jenkins.<init>(Jenkins.java:736)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:813)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at hudson.plugins.git.GitTool.onLoaded(GitTool.java:74)
      ... 13 more

        Attachments

          Issue Links

            Activity

            iker Iker Jimenez added a comment -

            I can confirm the same issue here.

            Last Jenkins release that works is 1.447

            haj031ch Hajo Eichler added a comment -

            I had the same problem with various versions of Jenkins - 1.447, 1.451 and 1.454
            I tried also different versions of the git plugin 1.1.16 and 1.1.15
            (All combination showed the same problem)

            In the end I found out that there is a conflict between plugins.
            I disabled the plugin "analysis-collector" and the exception does not appear anymore.

            Runs fine now with Jenkins 1.454 and git 1.1.16

            yvan Yvan Marques added a comment -

            I had the same issue and I removed the plugin Analysis collector and now it works.

            ohtake_tomohiro OHTAKE Tomohiro added a comment -

            Will be fixed in 1.462.
            See JENKINS-13448.

            iker Iker Jimenez added a comment -

            Still an issue with 1.473

            iker Iker Jimenez added a comment -

            Still happens with 1.473

            vladdu Vlad Dumitrescu added a comment -

            I just got this problem when updating to 1.489.

            benjamin_kemper Benjamin Kemper added a comment -

            It is happening to me also on 1.489.

            Stack trace:
            org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
            at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
            at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
            at jenkins.model.Jenkins.executeReactor(Jenkins.java:894)
            at jenkins.model.Jenkins.<init>(Jenkins.java:796)
            at hudson.model.Hudson.<init>(Hudson.java:81)
            at hudson.model.Hudson.<init>(Hudson.java:77)
            at hudson.WebAppMain$2.run(WebAppMain.java:214)
            Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
            at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
            at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
            at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
            at jenkins.model.Jenkins$7.runTask(Jenkins.java:883)
            at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
            at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
            at java.lang.Thread.run(Thread.java:722)
            Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:601)
            at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
            ... 8 more
            Caused by: java.lang.NullPointerException
            at hudson.plugins.git.GitTool.onLoaded(GitTool.java:74)
            ... 13 more

            Installed plugins:
            LDAP Plugin
            pam-auth
            ant
            javadoc
            Jenkins Subversion Plug-in
            Jenkins jQuery plugin
            Jenkins jQuery UI plugin
            Nested View Plugin
            Jenkins Multijob plugin
            Token Macro Plugin
            Jenkins SSH Slaves plugin
            Python Plugin
            Jenkins CVS Plug-in
            Maven Integration plugin
            Copy Artifact Plugin
            Log Parser Plugin
            ChuckNorris Plugin
            Jenkins Translation Assistance plugin
            Green Balls
            Jenkins Parameterized Trigger plugin

            mpapo Michael Pailloncy added a comment - - edited

            I've the same error with Jenkins 1.488 after an update of this four plugins :

            • CVS Plugin
            • Active Directory plugin
            • Scriptler Plugin
            • Translation Assistance Plugin

            deleted-After, rollback one by one each of this plugin, the bug seems to related with the CVS plugin (version 2.7)-deleted
            -> This error is not related with the Git Plugin.

            benjamin_kemper Benjamin Kemper added a comment -

            Michael, I tried your suggestion and downgraded the CVS plugin to 2.6 and it still happens. Also tried downgrading the SVN plugin also just in case.

            I'm trying to install the Dynamic Parameter plugin which requires and installs the git and the scriptlr plugins, maybe one of them is the cause?

            mpapo Michael Pailloncy added a comment -

            It's possibly the Scriptlr plugin which cause this issue. I thought it was not related as it was not in your list.

            mpapo Michael Pailloncy added a comment -

            Effectively, this is the Scriptlet plugin that cause this issue. I just install it and the problem reappeared.

            benjamin_kemper Benjamin Kemper added a comment -

            Thanks Michael, I manually installed scriptler 2.4.1 and it solved the issue.

            wernight wernight added a comment -

            It seems that installing the new dependency "Git Server Plugin" fixes this issue along with "FileBackedHttpGitRepository" exception.

            domi Dominik Bartholdi added a comment - - edited

            Please have a go with the newest version 2.5.1 and let me know if it fixes the issues for you.
            The plugin git-server is a required dependency now.

            domi Dominik Bartholdi added a comment -

            no reaction so far, please reopen if this is still an issue


              People

              • Assignee:
                domi Dominik Bartholdi
                Reporter:
                darrenleeweber Darren Weber
              • Votes:
                12 Vote for this issue
                Watchers:
                15 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: