Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12986

"Block build when downstream project is building" and fstrigger problem

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: fstrigger-plugin
    • Labels:
      None
    • Environment:
      fstrigger 0.27
      jenkins 1.451
    • Similar Issues:

      Description

      It seems that when you enable "Block build when downstream project is building" that scheduled polling still occurs. If you use fstrigger and a poll sees a file change when builds are blocked due to running downstream jobs, the timestamp or "fingerprint" or the file/folder watched still gets updated. This means that once the downstream job completes and the block is removed a new job should be triggered. Currently builds are NOT triggered as the plugin is comparing the contents observed during the blockout to current which are the same.

      When builds are blocked fstrigger should not update its "state" used for comparisons.

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          FSTrigger and its typology XTRigger is not aware about upstream/downstream.
          XTrigger plugins is aimed at excluding the usage of job dependencies.

          Could you just upload your job configuration files? I'll try to reproduce it.

          trbaker Trevor Baker added a comment -

          So after spending some more time with this configuration, I think it is working correctly. When the job is blocked by downstream activity, the trigger doesn't execute since the job that polls via fstrigger is blocked. I'l keep an eye on this, but unless you can see a way that the problem could manifest as described, I think this will get closed as a non-issue.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              trbaker Trevor Baker
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: