Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12995

Specifying custom phing build file does not work

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: phing-plugin
    • Labels:
    • Environment:
      root@jenkins:~# lsb_release -a
      Distributor ID: Ubuntu
      Description: Ubuntu 10.04.3 LTS
      Release: 10.04
      Codename: lucid
    • Similar Issues:

      Description

      Since the release of version 0.10, which properly fixes the issue in specifying that moduleroot should be default directory, I can no longer specify a custom phing build file path.

      looking for '/var/lib/jenkins/jobs/[SOME_JOB]/workspace/Build/Scripts/build.xml' ...
      [workspace] $ phing -buildfile build.xml build-all deploy [SOME_PROPERTIES_WERE_OMITTED]
      Buildfile: build.xml does not exist!

      This absolute path does actually exist, and 'Phing Build File' path is simply 'Build/Scripts/build.xml'. So it looks like it is looking for the file in the right location, but then reverts to using just the filename when executing phing.

        Attachments

          Activity

            People

            • Assignee:
              sogabe sogabe
              Reporter:
              danslo Daniel Sloof
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: