Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13063

Test report does not include all matching result xml files

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: junit-plugin
    • Labels:
      None

      Description

      We are using the option "Publish test results" for all our build jobs
      and are specifiying the following pattern for "Test results in XML format:"

      "_test/results/TEST_*.xml"

      When our ant build script is completed, there are the following files available matching this pattern:

      _test/results/TEST_hmm.xml
      _test/results/TEST_mssql2008.xml
      _test/results/TEST_oracle11g.xml
      _test/results/TESTS-TestSuites

      Since we updated to Jenkins 1.454, the file "_test/results/TEST_oracle11g.xml" will not be included anymore in the resulting test report (JOB/builds/TIMESTAMP/junitResult.xml) for all our builds.
      Only "TEST_hmm.xml" and "TEST_mssql2008.xml" are considered.

      Symptoms:

      • The build succeeds even if some of our Oracle tests fail
      • The test result trend graph shows the wrong number of test

      The listed files are all available in the specified directory and the HTML test report, which we create additionally, includes all test results.
      An update to Jenkins 1.455 did not help.
      Please let me know if you need any further information.

        Issue Links

          Activity

          kbond Kevin Bond added a comment - - edited

          I think I am having a similar issue. All my files are being included, but only the first testcase in each is being parsed.

          ganeshvattamwar ganesh vattamwar added a comment -

          I do have the same issue. In my *.xml file there are 2 testsuite and the trend is showing only the first testsuite and skipping the second one in the display.
          Is there any possibility to get this fixed within next weeks?

          pcorlatan Philip Corlatan added a comment -

          I'm currently checking if this issue is a duplicate of JENKINS-13214 (which has been fixed for the current release) and will give feedback today.

          kbond Kevin Bond added a comment -

          Looks the be the same issue, I will try out the latest release.

          pcorlatan Philip Corlatan added a comment -

          I tried it, but in my case the update did not help.

          pcorlatan Philip Corlatan added a comment -

          In the meanwhile the statistics are correct again.
          I will mark this issue as duplicate.


            People

            • Assignee:
              Unassigned
              Reporter:
              pcorlatan Philip Corlatan
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: