Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13137

Job build does not fail on failed SVN update

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.455, Subversion plugin 1.39, Subversion 1.6
    • Similar Issues:
      Show 5 results

      Description

      When a job is executed and one of the SVN repositories has invalid credentials set (and thus the SVN update fails) this does not fail the build!

      Updating https://stripped
      ERROR: Failed to update https://stripped
      org.tmatesoft.svn.core.SVNException: svn: OPTIONS /stripped failed
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:298)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:283)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:271)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:533)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:98)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1011)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getRepositoryUUID(DAVRepository.java:148)
      at org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:342)
      at org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:330)
      at org.tmatesoft.svn.core.wc.SVNUpdateClient.update(SVNUpdateClient.java:535)
      at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:401)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:136)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:136)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:788)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:769)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:753)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2099)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:287)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:60)
      at java.lang.Thread.run(Unknown Source)
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: OPTIONS /stripped failed
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
      ... 27 more
      Caused by: org.tmatesoft.svn.core.SVNAuthenticationException: svn: OPTIONS request failed on '/stripped'
      svn: OPTIONS of /stripped: 403 Forbidden (https://stripped)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:656)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:292)
      ... 26 more
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: OPTIONS request failed on '/stripped'
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
      at org.tmatesoft.svn.core.SVNErrorMessage.wrap(SVNErrorMessage.java:366)
      ... 28 more
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: OPTIONS of /stripped: 403 Forbidden (https://stripped)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:181)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:133)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPRequest.createDefaultErrorMessage(HTTPRequest.java:444)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPRequest.dispatch(HTTPRequest.java:189)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:379)

      no change for https://stripped since the previous build
      Triggering SLAVE_NOTE
      SLAVE_NOTE completed with result SUCCESS
      Triggering a new build of Project (Matrix) #60
      Finished: SUCCESS

        Attachments

          Issue Links

            Activity

            pdev Prashanth Devarajappa added a comment -

            This is also an issue if the update fails for any other reason such as failing to delete files when the local folders are locked.

            jkrag Jan Krag added a comment -

            We are having similar problems (also with different reasons for the SVNException) on:

            • Jenkins 1.465
            • Jenkins Subversion Plug-in 1.42

            As a tip for others having this problem, we are currently testing "Log Parser Plugin" as a workaround, where we have specifically added "error /SVNException/" as a parsing rule, and fail builds if this is found. Our specific SVN exception is not showing up anymore, so for the time being this workaround has not really been testet "the hard way" yet, but I hope it gives us somewhat of a safety net.

            kmart216 David Humeniuk added a comment -

            I'm having the same problem with Jenkins 1.475, SVN plug-in 1.42.

            egoitz egoitz garay added a comment -

            We are having the same problem, Jenkins 1.463 and SVN plug-in 1.39.

            kutzi kutzi added a comment -

            Should be fixed in 1.43


              People

              • Assignee:
                Unassigned
                Reporter:
                desolat Christoph Jaehnigen
              • Votes:
                5 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: