Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13245

Build not starting directly: pending - Waiting for next available executor on ...

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Last Saterday we upgraded from 1.451 to 1.456

      Sometimes when we trigger a job it comes in the queue with the message: (pending - Waiting for next available executor on .. servername ..)
      This even happens when the slave is totally idle, the job can start directly.
      After waiting for a minute it just starts ...

      Nothings helps to speed up the execution process

        Attachments

          Activity

          wbauer wbauer added a comment -

          I am seeing the same issues since version 1.452. Executors are all free, but the build does not start for minutes.

          mwebber mwebber added a comment -

          This is probably the same problem as JENKINS-12994

          dtka Daniel Tkatch added a comment -

          still the same at 1.457

          rcronk Robert Cronk added a comment -

          We're having the same problem and it's KILLING US!

          mwebber mwebber added a comment -

          Closing, as duplicate of JENKINS-12994


            People

            • Assignee:
              Unassigned
              Reporter:
              cbos Cees Bos
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: