Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13270

Occasional login failures using p4 ticket

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      1.456 Jenkins with latest perforce plugin
    • Similar Issues:

      Description

      Saw the following log whilst nothing has changed during the period:
      ========================================
      INFO: job_name_here #4437 main build action completed: SUCCESS
      Mar 27, 2012 6:11:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 6:21:10 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 6:31:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 6:41:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 6:51:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 7:01:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 7:01:18 AM hudson.model.Run run
      INFO: job_name_here #4438 main build action completed: SUCCESS
      Mar 27, 2012 7:11:10 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 7:21:10 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 7:31:10 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 7:43:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Login with '/tools/perforce/2010.1/bin.linux26x86/p4' failed: Login attempt failed: Password invalid.
      Mar 27, 2012 7:43:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Attempt to workaround p4 executable location failed
      com.tek42.perforce.PerforceException: Could not run perforce command.
      at hudson.plugins.perforce.HudsonP4DefaultExecutor.exec(HudsonP4DefaultExecutor.java:88)
      at com.tek42.perforce.parse.AbstractPerforceTemplate.p4Login(AbstractPerforceTemplate.java:596)
      at com.tek42.perforce.parse.AbstractPerforceTemplate.login(AbstractPerforceTemplate.java:566)
      at com.tek42.perforce.parse.AbstractPerforceTemplate.getPerforceResponse(AbstractPerforceTemplate.java:372)
      at com.tek42.perforce.parse.AbstractPerforceTemplate.getPerforceResponse(AbstractPerforceTemplate.java:292)
      at com.tek42.perforce.parse.Workspaces.getWorkspace(Workspaces.java:61)
      at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:1325)
      at hudson.plugins.perforce.PerforceSCM.compareRemoteRevisionWith(PerforceSCM.java:1019)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      at hudson.scm.SCM.poll(SCM.java:373)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1340)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:420)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:449)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: Cannot run program "/usr/bin/p4" (in directory "/projects/jenkins/jenkins_home"): java.io.IOException: error=2, No such file or directory
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
      at hudson.Proc$LocalProc.<init>(Proc.java:244)
      at hudson.Proc$LocalProc.<init>(Proc.java:216)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:707)
      at hudson.Launcher$ProcStarter.start(Launcher.java:338)
      at hudson.plugins.perforce.HudsonP4DefaultExecutor.exec(HudsonP4DefaultExecutor.java:79)
      ... 19 more
      Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
      at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
      at java.lang.ProcessImpl.start(ProcessImpl.java:65)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
      ... 24 more
      Problem: Login attempt failed: Password invalid.
      Mar 27, 2012 7:51:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 8:01:09 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 8:01:10 AM com.tek42.perforce.parse.AbstractPerforceTemplate login
      WARNING: Using p4 issued ticket.
      Mar 27, 2012 8:01:12 AM hudson.model.Run run
      INFO: job_name_here #4439 main build action completed: SUCCESS

        Attachments

          Activity

          lestin lestin added a comment -

          Hi Rob,

          Thanks for the hint, that works nicely.
          ===============
          + p4 -PCA84BE534B260418A89133C914BFE6B2 sync -f ...
          ... - file(s) up-to-date.
          ===============

          Is it possible that it can be set even when "expose P4PASSWD" option is off?
          As having that option, uses risk themselves of exposing their passwd in plain text.

          Thanks.

          Lestin

          rpetti Rob Petti added a comment -

          I will consider adding it as a separate option.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Rob Petti
          Path:
          src/main/java/hudson/plugins/perforce/PerforceSCM.java
          http://jenkins-ci.org/commit/perforce-plugin/16ef60deaf10719cc3877d9dc7507e34754046f4
          Log:
          JENKINS-13270 always put P4TICKET into the environment

          todo: add a separate option for P4TICKET, since some users may rightly consider the ticket as being sensitive information, and thus may want to disable it.

          dogfood dogfood added a comment -

          Integrated in plugins_perforce #210
          JENKINS-13270 always put P4TICKET into the environment (Revision 16ef60deaf10719cc3877d9dc7507e34754046f4)

          Result = SUCCESS
          Rob Petti :
          Files :

          • src/main/java/hudson/plugins/perforce/PerforceSCM.java
          lestin lestin added a comment -

          Hi Rob,

          Thanks for the quick turn around. Appreciated!

          Enjoy Easter Holiday ~

          Lestin


            People

            • Assignee:
              rpetti Rob Petti
              Reporter:
              lestin lestin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: