Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Ubuntu Server 64 bits
    • Similar Issues:

      Description

      Hi,

      I was updating my plugins then after update I can't access anymore my jenkins. I get the following error:

      [!] Erro

      org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:849)
      at jenkins.model.Jenkins.<init>(Jenkins.java:761)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$6.runTask(Jenkins.java:838)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at hudson.plugins.git.GitTool.onLoaded(GitTool.java:74)
      ... 13 more

        Attachments

          Issue Links

            Activity

            dextervip Rafael Tavares created issue -
            ohtake_tomohiro OHTAKE Tomohiro added a comment -

            I had a same issue.
            Git plugin and disk-usage plugin raised NPE even though those plugins have not been updated.
            I disabled analysis-collector and Jenkins now worked again.

            dextervip Rafael Tavares added a comment -

            Well I removed git plugin manually and It works again. Then I tried reinstalling git plugin and It stops jenkins again. I didn't try disable or remove analysis-collector yet.

            dextervip Rafael Tavares made changes -
            Field Original Value New Value
            Component/s analysis-collector [ 15710 ]
            ntfreak Spencer Oliver added a comment - - edited

            I am also seeing the NPE when using the git plugin - using analysis-collector v1.19 fixes everything for me.
            Just to clarify only analysis-collector was updated to cause the NPE.

            ohtake_tomohiro OHTAKE Tomohiro made changes -
            Link This issue is related to JENKINS-13394 [ JENKINS-13394 ]
            ohtake_tomohiro OHTAKE Tomohiro made changes -
            Link This issue is related to JENKINS-13385 [ JENKINS-13385 ]
            ohtake_tomohiro OHTAKE Tomohiro made changes -
            Link This issue is related to JENKINS-13379 [ JENKINS-13379 ]
            kasperg Kasper Garnæs added a comment -

            I've experienced the same problem.

            Downgrading analysis collector did not solve the problem here. Disabling analysis-collector did.

            vjuranek vjuranek added a comment -

            If you don't want to remove analysis-collector, installing Dashboard view plugin should solves the problem as well. It seems that Guice container doesn't distinguish optional extensions points properly and fails to load when some optional dependency is missing.

            ohtake_tomohiro OHTAKE Tomohiro added a comment -

            Will be fixed in 1.462.
            See JENKINS-13448.

            ohtake_tomohiro OHTAKE Tomohiro made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            mconlon Michael Conlon added a comment -

            I'm still seeing this in Jenkins 1.487.
            I've had Git Plugin installed for a very long time. When I installed Git-parameter plugin, things went haywire. However, manually removing Git parameter plugin did not fix the problem. Only removing Git plugin fixes it.

            lshatzer Larry Shatzer, Jr. made changes -
            Link This issue is related to JENKINS-12966 [ JENKINS-12966 ]
            jglick Jesse Glick made changes -
            Summary Jenkins stopped after updating plugins NPE from GitTool.onLoaded
            Component/s core [ 15593 ]
            Component/s analysis-collector [ 15710 ]
            jglick Jesse Glick made changes -
            Labels git jenkins plugins
            maruska Michal Maruska added a comment -

            Similar happened for me (after disabling/uninstalling a couple plugins & restart)

            Caused by: java.lang.NullPointerException
            	at hudson.plugins.git.GitTool.onLoaded(GitTool.java:105)
            	... 13 more
            

            This on 1.538

            This seems to let me work again:

            cd ~jenkins/plugins/
            mv git-client.jpi git-client.jpi.disabled
            

            If I look at the MANIFEST.MF in that jpi:

            Plugin-Version: 1.3.0
            Jenkins-Version: 1.480
            
            axeluhl Axel Uhl added a comment -

            Am on Jenkins 1.540 and am seeing the same problem. analysis-collector isn't installed, the "Dashboard view" plugin is available. Installing it didn't help. Here again goes the exception I'm seeing after restart:

            org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
            at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
            at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
            at jenkins.model.Jenkins.executeReactor(Jenkins.java:915)
            at jenkins.model.Jenkins.<init>(Jenkins.java:811)
            at hudson.model.Hudson.<init>(Hudson.java:81)
            at hudson.model.Hudson.<init>(Hudson.java:77)
            at hudson.WebAppMain$3.run(WebAppMain.java:221)
            Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
            at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:109)
            at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:169)
            at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
            at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
            at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
            at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
            at java.lang.Thread.run(Thread.java:722)
            Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:601)
            at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)
            ... 8 more
            Caused by: java.lang.NullPointerException
            at hudson.plugins.git.GitTool.onLoaded(GitTool.java:105)
            ... 13 more

            This problem has been going on for months now. Guys... we need this git support!

            redlab Balder VC added a comment -

            Updating git.jpi to version 2.0 seemed to fix it on our instance.

            redlab Balder VC added a comment -

            It returns when restarting jenkins. But installing the plugin does not give issues.

            markewaite Mark Waite added a comment -

            I was able to see a similar null pointer exception if I disabled the credentials plugin while the git plugin and the git client plugin were both enabled. When I restarted Jenkins, it failed to restart with the null pointer exception.

            After doing that, I removed plugins/credentials.jpi.disabled and restarted Jenkins. It started correctly. The credentials plugin must be enabled for the git plugin or the git client plugin (or both).

            There may need to be some core extension which will allow a plugin to explicitly declare that it depends on another plugin being enabled.

            axeluhl Axel Uhl added a comment -

            Thanks, Mark. I started over with a fresh Jenkins under Ubuntu, upgraded the .war file to the latest release (1.532.2 as of this writing) and installed the credentials plugin. Of course, I had to use the JGit implementation instead of an external git executable to get the benefits of the credentials plugin, but then, fetching from git worked like a charm.

            markewaite Mark Waite added a comment -

            I'm glad you were able to authenticate. The external git executable should also work with the credentials plugin.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 143845 ] JNJira + In-Review [ 190775 ]

              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                dextervip Rafael Tavares
              • Votes:
                5 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: