Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13446

Dependency graph points to localhost:8080

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When looking at https://integration.mediawiki.org/ci/view/All/job/MediaWiki-postgres-phpunit/depgraph-view/? with Konqueror, Firefox or Chrome, the link in the graph points to http://localhost:8080/ci/view/All/job/MediaWiki-postgres-phpunit/. I haven't confirmed whether this bug actually lies with Jenkins and/or which plugin, but "depgraph-view" soundn't familiar .

        Attachments

          Activity

          timlandscheidt Tim Landscheidt created issue -
          oldelvet Richard Mortimer added a comment -

          https://integration.mediawiki.org/ci/view/All/job/MediaWiki-postgres-phpunit/depgraph-view/graph.map

          is returning a URL containing localhost.

          <map id="_anonymous_0" name="_anonymous_0">
          <area shape="rect" href="http://localhost:8080/ci/view/All/job/MediaWiki-postgres-phpunit/" title="MediaWiki&#45;postgres&#45;phpunit" alt="" coords="27,27,307,75"/>
          </map>
          
          oldelvet Richard Mortimer added a comment -

          I think that this is likely cause by a misconfiguration at

          https://integration.mediawiki.org/ci/configure

          Look for "Jenkins URL" and set it to https://integration.mediawiki.org/ci you may need to restart Jenkins to make that take effect.

          timlandscheidt Tim Landscheidt added a comment -

          Thanks. I have posted your suggestion to https://bugzilla.wikimedia.org/show_bug.cgi?id=35982; I will close this bug here once WMF OPS has confirmed it (or follow up here if there is additional information).

          timlandscheidt Tim Landscheidt added a comment -

          Per https://bugzilla.wikimedia.org/show_bug.cgi?id=35982#c1, "Jenkins URL" is set to "https://integration.mediawiki.org/ci/", so the bug seems to be in Jenkins.

          andreyev Andreyev Melo added a comment -

          I don't know if it make any sense, but in our Enterprise instance it's works fine. It shows on footer "Jenkins ver. 1.424.6.1" so I guess that it is a kind of LTS, then it's equivalent to an "old" and free version.

          BTW, there are no occurrences to hostname or URL in config.xml or any file in JENKINS_HOME.

          In these instance we installed version 0.2 of this plugin.

          hashar Antoine Musso added a comment -

          Still there with Jenkins 1.472 and Dependency Graph 0.2.

          Source code is on github at https://github.com/jenkinsci/depgraph-view-plugin
          The culprit is
          src/main/java/hudson/plugins/depgraph_view/DotStringGenerator.java which does
          the following:

          private String projectToNodeString(AbstractProject<?, ?> proj)

          { return escapeString(proj.getFullDisplayName()) + " [href=" + getEscapedProjectUrl(proj) + "]"; }

          private String getEscapedProjectUrl(AbstractProject<?, ?> proj)

          { return escapeString(Hudson.getInstance().getRootUrlFromRequest() + proj.getUrl()); }

          getRootUrlFromRequest is most probably getting the URL based on whatever HTTP
          GET Jenkins received. In our setup, there is a proxy in front of Jenkins and
          hence any requests are made to 127.0.0.1:8080.

          The plugin need to instead use whatever "Jenkins URL" is configured.

          Our Apache conf makes https://integration.mediawiki.org/ci to be proxied to http://localhost:8080/ci

          ProxyPass /ci http://localhost:8080/ci
          ProxyPassReverse /ci http://localhost:8080/ci
          ProxyRequests Off

          <Proxy http://localhost:8080/ci*>
          Order deny,allow
          Allow from all
          </Proxy>

          hashar Antoine Musso added a comment -

          .dot file on Wikimedia Jenkins installation.

          Generated with Jenkins 1.472 and depgraph-view 0.2.

          hashar Antoine Musso made changes -
          Field Original Value New Value
          Attachment wmf-jenkins.dot [ 22077 ]
          wolfs Stefan Wolf made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          wolfs Stefan Wolf added a comment -

          Should be solved in version 0.5. Please confirm.

          wolfs Stefan Wolf made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          hashar Antoine Musso added a comment -

          That indeed fixed the issue. Thanks!

          wolfs Stefan Wolf made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 143912 ] JNJira + In-Review [ 205790 ]

            People

            • Assignee:
              wolfs Stefan Wolf
              Reporter:
              timlandscheidt Tim Landscheidt
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: