Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13517

CopyProjectLink plugin: does not work with jobs using 'display name' feature

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      In Jenkins 1.454, the copy project link plugin does not work when copying a job which is using the new 'display name' feature.

      You can repro with these steps:

      • create job A and go to the configure page.
      • click the Advanced... button next in the 'Advanced Project Options section.
      • set the Display Name to something like 'My job'
      • save the config page
      • on the main job page, click the 'Copy project' link to copy it
      • note the URL has the (internal) job name – 'A' (good)
      • enter a new job name, and click OK.

      At this point, you get an error message of the form:

      Error
      No such job: My job

      A workaround is to use the normal 'new job' approach for copying a job.

        Attachments

          Activity

          sroth Steve Roth created issue -
          gpgarrettboast Garrett Boast made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          gpgarrettboast Garrett Boast added a comment -

          I've submitted a pull request that resolves this: https://github.com/jenkinsci/copy-project-link-plugin/pull/3

          tsniatowski Tomasz Śniatowski added a comment -

          This is still a problem, can anyone take a look at the pull request?

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: etherfoundry
          Path:
          src/main/java/hudson/plugins/copyProjectLink/CopyAction.java
          http://jenkins-ci.org/commit/copy-project-link-plugin/79bc4c465f4a4611d00cb1027f95ca6ac5c1f8fe
          Log:
          Resolving issue JENKINS-13517 caused by using DisplayName that prevented copying of projects with a Display Name set.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Oliver Gondža
          Path:
          src/main/java/hudson/plugins/copyProjectLink/CopyAction.java
          http://jenkins-ci.org/commit/copy-project-link-plugin/4fa35d6ba88ab35513dcf213ed3f17c2817ffe3a
          Log:
          Merge pull request #3 from etherfoundry/master

          Resolving issue JENKINS-13517 (DisplayName)

          Compare: https://github.com/jenkinsci/copy-project-link-plugin/compare/eb604e69ca94...4fa35d6ba88a

          olivergondza Oliver Gondža added a comment -

          Fixed in 1.4.

          olivergondza Oliver Gondža made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 143983 ] JNJira + In-Review [ 190842 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              sroth Steve Roth
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: