Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13577

Promotion completes successfully but EnvInject error is displayed at the bottom of the promotion log

    Details

      Description

      I have EjnvInject Plugin 1.44 and Publish over SSH Plugin 1.6 installed for Jenkins Version 1.456. When I perform a build promotion it completes successfully but displays a EnvInject Error at the bottom of the promotion log. Looks like this is because of some incompatibility between EnvInject and Publish over SSH Plugins. Below is the log with the EnjInject error.

      build BapSshPromotionPublisherPlugin[delegate=BapSshPublisherPlugin[consolePrefix=SSH: ,delegate=BPInstanceConfig[publishers=[BapSshPublisher[configName=DEV BIG-IP,verbose=false,transfers=[BapSshTransfer[sourceFiles=scripts/Environments/SSPQA/*,excludes=/_jdbc.properties,removePrefix=scripts/Environments/,remoteDirectory=,remoteDirectorySDF=false,flatten=false,cleanRemote=false,execCommand=chmod 755 SSPQA -R

      ,execTimeout=120000,pseudoTty=false]],useWorkspaceInPromotion=false,usePromotionTimestamp=true,retry=<null>,label=<null>,credentials=<null>]],continueOnError=false,failOnError=true,masterNodeName=<null>,alwaysPublishFromMaster=false,paramPublish=<null>]]] SUCCESS
      [EnvInject] - [ERROR] - SEVERE ERROR occurs: Job type hudson.plugins.promoted_builds.PromotionProcess@18e8006[SSP-CAS_WS-BUILD/promotion/Promote to SSP QA] is not supported

        Activity

        Hide
        gbois Gregory Boissinot added a comment -

        It should be fixed with EnvInject 1.46+.
        Could you test with this version or a greater version?
        Do not hesitate to reopen it if the problem persists.

        Show
        gbois Gregory Boissinot added a comment - It should be fixed with EnvInject 1.46+. Could you test with this version or a greater version? Do not hesitate to reopen it if the problem persists.
        Hide
        skumar suresh kukalakuntla added a comment -

        Thank You so much Greg.

        I updated the EnvInject plugin to Version 1.48 and it fixed the issue.

        Show
        skumar suresh kukalakuntla added a comment - Thank You so much Greg. I updated the EnvInject plugin to Version 1.48 and it fixed the issue.

          People

          • Assignee:
            gbois Gregory Boissinot
            Reporter:
            skumar suresh kukalakuntla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: