Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13674

AD Auth with Matrix authentication now requires LDAP name rather than username

    Details

    • Similar Issues:

      Description

      As of active-directory 1.27, the system resolves the full LDAP name for the user, and apparently attempts to use this rather than the username for comparison in matrix based authentication. This is a pain, since it's much easier and more consistent to use usernames for rights management (plus that's how it used to work).

        Attachments

          Activity

          kstarling Keith Starling created issue -
          algorhythm99 Jason Wooster added a comment -

          Usernames in the authentication matrix DO work.
          However it is case-sensitive and must match the user's sAMAccountName casing in AD.

          zoufala Andreas Zoufal added a comment -

          I'm sorry but I cannot get it to work. After updating to 1.27 I can login with my usual username, but I don't have the right to manage jenkins, I'm just a viewer now. There is something what has changed.
          I had to restore the old version manually (I hope I did everything right), in ${JENKINS_HOME}/plugins I had to copy active-directory.bak over active-directory.jpi. Now I works again with the old version.

          salvojo John Salvo added a comment -
          kohsuke Kohsuke Kawaguchi made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 144141 ] JNJira + In-Review [ 190928 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              kstarling Keith Starling
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: