Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13737

Javascript error when selecting "Editable Email Notification"

    Details

    • Similar Issues:

      Description

      In Jenkins ver. 1.463, when selecting "Editable Email Notification" in the "Add post-build action", getting the following Javascript error

      Message: 'emailExtInit' is undefined
      Line: 480
      Char: 17
      Code: 0
      URI: http://myserver:8080/static/f11a6618/scripts/hudson-behavior.js

        Attachments

          Issue Links

            Activity

            Hide
            kevinhcross Kevin Cross added a comment -

            I have just seen the exact same problem using Firefox 3.6.23 with the same versions of Jenkins and Email-ext.

            Error: emailExtInit is not defined
            Source File: http://dev-server:23900/static/dec3f228/scripts/hudson-behavior.js
            Line: 480

            Show
            kevinhcross Kevin Cross added a comment - I have just seen the exact same problem using Firefox 3.6.23 with the same versions of Jenkins and Email-ext. Error: emailExtInit is not defined Source File: http://dev-server:23900/static/dec3f228/scripts/hudson-behavior.js Line: 480
            Hide
            mcnicholls Michael Nicholls added a comment -

            I'm seeing exactly the same.

            Jenkins 1.463, email-ext 2.20 Firefox 12

            Timestamp: 10/05/2012 17:35:09
            Error: emailExtInit is not defined
            Source File: http://2008-edit-build:8080/static/477b254c/scripts/hudson-behavior.js
            Line: 480

            I saw there were problems with email-ext and the promotion plugin before.
            I have the promotion plugin installed and i'm trying to add an Editable Email as a promotion action,
            although I can't add an Editable Email as a normal post build action.

            Show
            mcnicholls Michael Nicholls added a comment - I'm seeing exactly the same. Jenkins 1.463, email-ext 2.20 Firefox 12 Timestamp: 10/05/2012 17:35:09 Error: emailExtInit is not defined Source File: http://2008-edit-build:8080/static/477b254c/scripts/hudson-behavior.js Line: 480 I saw there were problems with email-ext and the promotion plugin before. I have the promotion plugin installed and i'm trying to add an Editable Email as a promotion action, although I can't add an Editable Email as a normal post build action.
            Hide
            edalquist Eric Dalquist added a comment -

            Accidentally assigned to me

            Show
            edalquist Eric Dalquist added a comment - Accidentally assigned to me
            Hide
            edalquist Eric Dalquist added a comment -

            Seeing the same issue in Chrome 18.0.1025.168

            Email EXT Plugin - 2.20
            Jenkins - 1.463

            From the chrome JS console:

            Uncaught ReferenceError: emailExtInit is not defined
            (anonymous function)
            (anonymous function)hudson-behavior.js:480
            nexthudson-behavior.js:498
            (anonymous function)hudson-behavior.js:481
            nexthudson-behavior.js:498
            script.onload.script.onreadystatechangehudson-behavior.js:2558
            
            Show
            edalquist Eric Dalquist added a comment - Seeing the same issue in Chrome 18.0.1025.168 Email EXT Plugin - 2.20 Jenkins - 1.463 From the chrome JS console: Uncaught ReferenceError: emailExtInit is not defined (anonymous function) (anonymous function)hudson-behavior.js:480 nexthudson-behavior.js:498 (anonymous function)hudson-behavior.js:481 nexthudson-behavior.js:498 script.onload.script.onreadystatechangehudson-behavior.js:2558
            Hide
            sbellus Stefan Bellus added a comment - - edited

            I'm seeing exactly the same.

            Jenkins 1.463, email-ext 2.20 Firefox 11

            Show
            sbellus Stefan Bellus added a comment - - edited I'm seeing exactly the same. Jenkins 1.463, email-ext 2.20 Firefox 11
            Hide
            slide_o_mix Alex Earl added a comment -

            Actually, with a fresh install of Jenkins 1.463 and Email-ext 2.20, I do not see any JS errors and I am able to add it as a post-build action. Please give more information for debug.

            Show
            slide_o_mix Alex Earl added a comment - Actually, with a fresh install of Jenkins 1.463 and Email-ext 2.20, I do not see any JS errors and I am able to add it as a post-build action. Please give more information for debug.
            Hide
            slide_o_mix Alex Earl added a comment -

            Sorry, I take that back, I hit the wrong button. The issue looks like that the first eval'd script somehow loses its state. The first script initializes the emailExtInit variable and subsequent scripts use it.

            Show
            slide_o_mix Alex Earl added a comment - Sorry, I take that back, I hit the wrong button. The issue looks like that the first eval'd script somehow loses its state. The first script initializes the emailExtInit variable and subsequent scripts use it.
            Hide
            evilantnie Anthony Mendonca added a comment -

            I have the same problem on Ubuntu, jenkins1.463 and email-ext 2.20. I had the promotion plugin installed but wasn't using it on any projects. I also uninstalled the promotion plugin and still have this issue.

            Show
            evilantnie Anthony Mendonca added a comment - I have the same problem on Ubuntu, jenkins1.463 and email-ext 2.20. I had the promotion plugin installed but wasn't using it on any projects. I also uninstalled the promotion plugin and still have this issue.
            Hide
            slide_o_mix Alex Earl added a comment -

            Yes, this issue will affect ALL users who are using 1.463 regardless of browser or OS. It has to do with the change to the dropdown post-build that was put in recently. I am in the process of debugging it. It has nothing to do with the promotions plugin and everything to do with the version of Jenkins you are running.

            Show
            slide_o_mix Alex Earl added a comment - Yes, this issue will affect ALL users who are using 1.463 regardless of browser or OS. It has to do with the change to the dropdown post-build that was put in recently. I am in the process of debugging it. It has nothing to do with the promotions plugin and everything to do with the version of Jenkins you are running.
            Hide
            kellys Kelly Schoenhofen added a comment -

            Let us know when you have something, we're affected by the same issue.

            What is the xml so we can manually enable this in a job's config file?

            Show
            kellys Kelly Schoenhofen added a comment - Let us know when you have something, we're affected by the same issue. What is the xml so we can manually enable this in a job's config file?
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: slide
            Path:
            src/main/resources/hudson/plugins/emailext/ExtendedEmailPublisher/config.jelly
            http://jenkins-ci.org/commit/email-ext-plugin/ee715fbd1bd81e83cb9501c311fd04f309431a2c
            Log:
            FIX JENKINS-13737

            • Workaround issue with eval'd jscript code by making the variable window level (global)
            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: slide Path: src/main/resources/hudson/plugins/emailext/ExtendedEmailPublisher/config.jelly http://jenkins-ci.org/commit/email-ext-plugin/ee715fbd1bd81e83cb9501c311fd04f309431a2c Log: FIX JENKINS-13737 Workaround issue with eval'd jscript code by making the variable window level (global)
            Hide
            ldolan Leo Dolan added a comment - - edited

            I have made the changes locally as specified in the link above (deleted three lines and added three lines), and validated that it does work now for me.

            Note, the path to the file on my system (OEL5.5) was:

            /var/lib/jenkins/plugins/email-ext/WEB-INF/classes/hudson/plugins/emailext/ExtendedEmailPublisher/config.jelly

            Show
            ldolan Leo Dolan added a comment - - edited I have made the changes locally as specified in the link above (deleted three lines and added three lines), and validated that it does work now for me. Note, the path to the file on my system (OEL5.5) was: /var/lib/jenkins/plugins/email-ext/WEB-INF/classes/hudson/plugins/emailext/ExtendedEmailPublisher/config.jelly
            Hide
            slide_o_mix Alex Earl added a comment -

            Put in place a workaround to have the custom JS object made a global.

            Show
            slide_o_mix Alex Earl added a comment - Put in place a workaround to have the custom JS object made a global.
            Hide
            amitanand123 amit anand added a comment -

            I am facing same problem with Jenkins ver. 1.463 and Jenkins ver. 1.464 with Chrome browser19.0.1084.46 m

            Work around is also not working

            Show
            amitanand123 amit anand added a comment - I am facing same problem with Jenkins ver. 1.463 and Jenkins ver. 1.464 with Chrome browser19.0.1084.46 m Work around is also not working
            Hide
            slide_o_mix Alex Earl added a comment -

            Then try installing 2.21. It works for me on those versions.

            Show
            slide_o_mix Alex Earl added a comment - Then try installing 2.21. It works for me on those versions.
            Hide
            kellys Kelly Schoenhofen added a comment -

            Thanks, 2.21 works for me!

            Show
            kellys Kelly Schoenhofen added a comment - Thanks, 2.21 works for me!
            Hide
            slide_o_mix Alex Earl added a comment -

            Verified as working in 2.21

            Show
            slide_o_mix Alex Earl added a comment - Verified as working in 2.21
            Hide
            jmbarroso Juan Manuel Barroso added a comment -

            Hi,

            Jenkins automatic updates doesn't detect version 2.21. Do I have to manually install the version 2.21 of the plugin?

            Regards,

            Juanma

            Show
            jmbarroso Juan Manuel Barroso added a comment - Hi, Jenkins automatic updates doesn't detect version 2.21. Do I have to manually install the version 2.21 of the plugin? Regards, Juanma
            Hide
            slide_o_mix Alex Earl added a comment -

            What version of core are you using? 2.21 was upgraded to depend on the latest LTS release.

            Show
            slide_o_mix Alex Earl added a comment - What version of core are you using? 2.21 was upgraded to depend on the latest LTS release.
            Hide
            jmbarroso Juan Manuel Barroso added a comment -

            The problem is solved, it appears that Jenkins only needed time to detect the update. Thanks

            Show
            jmbarroso Juan Manuel Barroso added a comment - The problem is solved, it appears that Jenkins only needed time to detect the update. Thanks

              People

              • Assignee:
                slide_o_mix Alex Earl
                Reporter:
                javaneo Noel Bernardez
              • Votes:
                7 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: