Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13738

multi-configuration jobs don't expose axes as variables to EnvVars

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I've got a multi-configuration job, and created a user-defined axis "ANIMAL" with one value, "zebra". Then I ran a publisher which in perform() did:

      listener.getLogger().println(build.getEnvironment(listener));

      The problem is that build.getEnvironment(listener).expand("$ANIMAL") does not find anything to expand. This is because it isn't in the EnvVars. The closest thing I found is "JOB_NAME=bar/ANIMAL=zebra", but there's no "ANIMAL", which seems weird, since it is exposed as an environment variable to build-steps.

        Attachments

          Activity

          mcrooney mcrooney created issue -
          oleg_nenashev Oleg Nenashev made changes -
          Field Original Value New Value
          Component/s matrix-project [ 18765 ]
          oleg_nenashev Oleg Nenashev added a comment -

          Cannot reproduce on the newest plugin version

          oleg_nenashev Oleg Nenashev made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 144205 ] JNJira + In-Review [ 190965 ]
          nareshg4 Naresh G added a comment -

          Hi, am getting a similar issue when using the multi configuration job.
          I want to publish set of html files which are created as part of multi config job.
          What i can do is hard code the file names to get it displayed but what i want to achieve is publish all html files as part the job using a variable.


            People

            • Assignee:
              Unassigned
              Reporter:
              mcrooney mcrooney
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: