Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14001

Jabber plugin cannot be installed without maven plugin

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core, jabber-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.447 installed from Debian testing package, Jabber 1.22, Instant-messaging 1.21.
    • Similar Issues:

      Description

      I couldn't install instant-messaging and jabber plugins on a fresh installation on Jenkins. After installing them and restarting Jenkins, the only visual clue I got was that those plugins were not on the installed plugins list.

      Digging into the log I found:

      WARNING: Adding dependent install of instant-messaging for plugin jabber
      [...]
      SEVERE: Failed Loading plugin instant-messaging
      java.io.IOException: Dependency maven-plugin (1.392) doesn't exist
              at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:434)
              at hudson.PluginManager$2$1$1.run(PluginManager.java:293)
              at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
              at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
              at jenkins.model.Jenkins$5.runTask(Jenkins.java:799)
              at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
              at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
              at java.lang.Thread.run(Thread.java:679)
      May 31, 2012 3:41:49 PM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Loading plugin jabber
      java.io.IOException: Dependency maven-plugin (1.392), instant-messaging (1.21) doesn't exist
              at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:434)
              at hudson.PluginManager$2$1$1.run(PluginManager.java:293)
              at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
              at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
              at jenkins.model.Jenkins$5.runTask(Jenkins.java:799)
              at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
              at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
              at java.lang.Thread.run(Thread.java:679)
      [...]
      SEVERE: Failed to install Instant Messaging Plugin
      hudson.util.IOException2: Failed to dynamically deploy this plugin
              at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1137)
              at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:955)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
              at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
              at java.util.concurrent.FutureTask.run(FutureTask.java:166)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
              at java.lang.Thread.run(Thread.java:679)
      Caused by: hudson.util.IOException2: Failed to install instant-messaging plugin
              at hudson.PluginManager.dynamicLoad(PluginManager.java:365)
              at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1133)
              ... 7 more
      Caused by: java.io.IOException: Dependency maven-plugin (1.392) doesn't exist
              at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:434)
              at hudson.PluginManager.dynamicLoad(PluginManager.java:355)
              ... 8 more
      

        Attachments

          Activity

          kutzi kutzi added a comment -

          Should be fixed in instant-messaging 1.22+


            People

            • Assignee:
              kutzi kutzi
              Reporter:
              liori Tomasz Melcer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: