Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14117

The plugin hasn't been performed correctly: remote file operation failed

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: xunit-plugin
    • Labels:
    • Environment:
      Jenkins 1.469
      Linux master
      Windows 7 slaves
    • Similar Issues:

      Description

      We got always this error!
      Seems the same like http://issues.hudson-ci.org/browse/HUDSON-7081
      We can reproduce it.

      monospaced
      ========== Build: 1 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========
      [G_master_xUnit_test] $ cmd /c call D:\TEMP\hudson426846465795215396.bat
      [xUnit] [INFO] - Starting to record.
      [xUnit] [INFO] - Processing BoostTest-1.x (default)
      [xUnit] [WARNING] - Can't create the path d:_HUDSON\workspace\G_master_xUnit_test\generatedJUnitFiles. Maybe the directory already exists.
      [xUnit] [INFO] - [BoostTest-1.x (default)] - 30 test report file(s) were found with the pattern 'build/bin/x64/DEBUG/Test*.xml' relative to 'd:_HUDSON\workspace\G_master_xUnit_test' for the testing framework 'BoostTest-1.x (default)'.
      [xUnit] [ERROR] - There is at least one problem. Check the Jenkins system log for more information. (if you don't have configured yet the system log before, you have to rebuild).
      [xUnit] [INFO] - Processing BoostTest-1.x (default)
      [xUnit] [WARNING] - Can't create the path d:_HUDSON\workspace\G_master_xUnit_test\generatedJUnitFiles. Maybe the directory already exists.
      [xUnit] [INFO] - [BoostTest-1.x (default)] - No test report file(s) were found with the pattern 'build/bin/x64/Release/Test*.xml' relative to 'd:_HUDSON\workspace\G_master_xUnit_test' for the testing framework 'BoostTest-1.x (default)'. Did you enter a pattern relative to the correct directory? Did you generate the result report(s) for 'BoostTest-1.x (default)'?
      [xUnit] [ERROR] - No test reports found for the metric 'BoostTest' with the resolved pattern 'build/bin/x64/Release/Test*.xml'. Configuration error?.
      [xUnit] [ERROR] - The plugin hasn't been performed correctly: remote file operation failed: d:/_HUDSON/workspace/G_master_xUnit_test at hudson.remoting.Channel@693ed7e2:MUCBPC002
      Build step 'Publish xUnit test result report' changed build result to FAILURE
      Build step 'Publish xUnit test result report' marked build as failure
      monospaced

        Attachments

          Activity

          thomas_oeding Thomas Oeding created issue -
          coreyoconnor Corey O'Connor added a comment -

          I am able to reproduce this randomly. This appears to depend on the speed at which a slave fsync's the directory containing the XML data. The only entry from the log is:

          [xUnit] [ERROR] - The plugin hasn't been performed correctly: remote file operation failed: /var/lib/role-jenkins-alfred/jenkins_slave_data_root/workspace/qa-tools-ui-test-support-functional-tests at hudson.remoting.Channel@a907d8a:alfred_5
          

          No additional information is output to either the slave log or master log.

          medington Mark Edington added a comment -

          I started running into this, or another similar problem after updating from 1.55 to 1.77. There really isn't much in the build log to go on, is there something I can do to track down the cause? Here is the output from the failed build:

          [xUnit] [ERROR] - The plugin hasn't been performed correctly: remote file operation failed: c:\Jenkins\workspace\Findnsave_ContentApi at hudson.remoting.Channel@53df0f73:Win2012VM
          
          mindjiver Peter Jönsson added a comment -

          If your job is running on a remote slave I think it was this bug which was fixed:

          JENKINS-21220 - https://github.com/mindjiver/xunit-plugin/commit/719b511a87bf0ffa31be28c0f9e4d05b9e185e0c

          mindjiver Peter Jönsson added a comment -

          So please try xunit 1.78 and see if the problem persists.

          medington Mark Edington added a comment -

          1.78 is working without any error for me now. Thanks.

          thomas_oeding Thomas Oeding added a comment -

          1.78 works fine for me too

          thomas_oeding Thomas Oeding added a comment -

          fixed in 1.78

          thomas_oeding Thomas Oeding made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s current [ 10162 ]
          Resolution Fixed [ 1 ]
          ajpurkiss ajpurkiss added a comment -

          With 1.101 this issue seems to have returned, it only happens once in a while

          [xUnit] [INFO] - Starting to record.
          [xUnit] [INFO] - Processing JUnit
          [xUnit] [INFO] - [JUnit] - 230 test report file(s) were found with the pattern '*/build/test-results//.xml' relative to '/home/builduser/jenkins/workspace/XXXXXXX' for the testing framework 'JUnit'.
          [xUnit] [ERROR] - The plugin hasn't been performed correctly: remote file operation failed: /home/builduser/jenkins/workspace/XXXXXXX at hudson.remoting.Channel@18ef946:xxxxxxxx: java.io.IOException: Remote call on xxxxxxxxx failed
          Build step 'Process xUnit test result report' changed build result to FAILURE

          ajpurkiss ajpurkiss made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          directhex Jo Shields added a comment -

          Same here: https://jenkins-master-2.cloudapp.net/job/test-monodevelop-mainline/label=ubuntu-1404-amd64/3146/console

          I can definitely see that file exists at that path & contains data.

          bernicc Bernard Ladenthin added a comment - - edited

          Same here.

          First it looks from an upgrade from <org.jenkinsci.plugins.xunit.XUnitBuilder plugin="xunit@1.96"> to <org.jenkinsci.plugins.xunit.XUnitBuilder plugin="xunit@1.101">

          The slave is a Windows 7 x64 Machine.

          [xUnit] [INFO] - Starting to record.
          [xUnit] [INFO] - Processing JUnit
          [xUnit] [INFO] - [JUnit] - 1 test report file(s) were found with the pattern 'surefire-reports/TEST-*.xml' relative to 'J:\JenkinsSlave\workspace\S970 STester STest' for the testing framework 'JUnit'.
          [xUnit] [ERROR] - The plugin hasn't been performed correctly: remote file operation failed: J:\JenkinsSlave\workspace\S970 STester STest at hudson.remoting.Channel@ea9617:ST-SikuliTester: java.io.IOException: java.io.IOException: Failed to read J:\JenkinsSlave\workspace\S970 STester STest\generatedJUnitFiles\JUnit\TEST--346453655.xml
          Build step 'Process xUnit test result report' changed build result to FAILURE
          

          A deeper analysis:
          After i've deleted the local repository, now the Test-*.xml files contain in the second line a comma in the xml.

          The 2,052.575 produces the error.

          <?xml version="1.0" encoding="UTF-8"?>
          <testsuite name="de.S" time="2,052.575" tests="9" errors="0" skipped="0" failures="0">

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 144748 ] JNJira + In-Review [ 186063 ]
          nfalco Nikolas Falco made changes -
          Assignee Gregory Boissinot [ gbois ] Nikolas Falco [ nfalco ]
          nfalco Nikolas Falco added a comment -

          Please try with lastest version of Jenkins and the plugin, i could not reproduce this scenario.

          nfalco Nikolas Falco made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              nfalco Nikolas Falco
              Reporter:
              thomas_oeding Thomas Oeding
            • Votes:
              5 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: