Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14187

The trac publisher plugin does not support multi-repo trac instances

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: trac-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      As of trac 0.12, multiple repositories can be added to trac. The plugin only takes the base trac url as a parameter, and only generates URLs for the default repository of a given trac instance. If the trac instance doesn't have a default repository, or if the repository in question is something other than the default repository, then links to the /browser/ and /changeset/ (and possibly other) urls will be broken.

      The other thing that is needed as a parameter to the plugin is the name of the repository. So for example if you have two repositories on your trac instance at example.com, the url for the browser will be http://www.example.com/browser/foo/ or http://www.example.com/browser/bar/ if the repository names are foo and bar. If the default repository is being used, you may omit the repository name from the URL. I would expect there to be an advanced section that allows you to check a box for the case that a given trac instance has a non-default repository that you're trying to work with.

      This feature is new in trac as of 0.12 if I recall correctly.

        Attachments

          Issue Links

            Activity

            programmerq Jeff Anderson added a comment -

            whoops, looks like I opened a duplicate of https://issues.jenkins-ci.org/browse/JENKINS-13365. Closing this one.

            tafthorne Thomas A. F. Thorne added a comment -

            I always get this language mixed up. I take it that duplicates _are the important bugs at the top of the pile and _is duplicated by suggests things that are beneath the title bug?


              People

              • Assignee:
                Unassigned
                Reporter:
                programmerq Jeff Anderson
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: