Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14275

Wrong folder permissions when downloading artifacts

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      ubunutu with jenkins 1.472
    • Similar Issues:

      Description

      While downloading the artifact using the link: 'all files in zip' the archive received has rw-rw-rw- permissions on folder while r-x is at least expected

      Without the execute permission, while unziping, you can't change directory (permissions denied) You need to change manually the permissions

      The jenkins version #1.404 was working fine

        Attachments

          Activity

          hdietze Heiko Dietze added a comment -

          We see the same issue also in the LTS release 1.509.1

          danielbeck Daniel Beck added a comment -

          Cannot reproduce on 1.567. When running unzip from the command line, the folders are executable afterwards.


            People

            • Assignee:
              Unassigned
              Reporter:
              xdelas Xav DELAS
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: