Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: dry-plugin
    • Labels:
      None
    • Environment:
      Linux with Ubuntu 10.04 LTS & Oracle Java 1.6.0_33-b03
    • Similar Issues:

      Description

      I configured a slave to handle some builds that we're taking too much time in our server. Now some of the builds on the slave fail with hudson.util.IOException2 caused by a StackOverflowError.

      I've attached the build log for the build that fails most often.

        Attachments

          Activity

          evernat evernat added a comment -

          Is it reproduced with a recent Jenkins version?

          oleg_nenashev Oleg Nenashev added a comment -

          The issue seems to be somehow invoked by the "dry" plugin.
          I suppose the analysis should be started from this plugin.

          hudson.util.IOException2: remote file operation failed: /opt/jenkins/workspace/Test at hudson.remoting.Channel@294d0f1a:slave1
          at hudson.FilePath.act(FilePath.java:780)
          at hudson.FilePath.act(FilePath.java:766)
          at hudson.plugins.dry.DryPublisher.perform(DryPublisher.java:169)
          at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:338)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
          at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:697)
          at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:672)
          at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:650)
          at hudson.model.Build$RunnerImpl.post2(Build.java:162)
          at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:619)
          at hudson.model.Run.run(Run.java:1429)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:238)
          Caused by: java.io.IOException: Remote call on slave1 failed
          at hudson.remoting.Channel.call(Channel.java:690)
          at hudson.FilePath.act(FilePath.java:773)
          ... 13 more
          Caused by: java.lang.StackOverflowError
          at java.lang.reflect.InvocationTargetException.<init>(InvocationTargetException.java:54)
          at sun.reflect.GeneratedMethodAccessor41.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)

          drulli Ulli Hafner added a comment -

          @Oleg: Did you reproduce it? This issue is two years old!

          oleg_nenashev Oleg Nenashev added a comment - - edited

          @Ulli
          No. I've just analyzed the issue and assigned it to the best-fit component according to the attached stacktraces.
          There's no such issues in the plugin's changelog, hence I've decided to leave the issue open.

          Most probably, the issue is outdated.

          drulli Ulli Hafner added a comment -

          @Oleg: ok thanks for checking that.

          @Juan: If this problem is still valid please reopen this issue.

          shwetabg shweta G added a comment -

          Hi,

          I am getting below error with dry plugin, please help.

          09:50:50 [DRY] Collecting duplicate code analysis files...
          09:51:01 ERROR: Publisher hudson.plugins.dry.DryPublisher aborted due to exception
          09:51:01 java.io.IOException: remote file operation failed: D:\Jenkins\for-dev\workspace\dev_Q_Build at hudson.remoting.Channel@1434e90:Quick Build Slave for dev: java.io.IOException: Remote call on Quick Build Slave for dev failed
          09:51:01 at hudson.FilePath.act(FilePath.java:976)
          09:51:01 at hudson.FilePath.act(FilePath.java:958)
          09:51:01 at hudson.plugins.dry.DryPublisher.perform(DryPublisher.java:179)
          09:51:01 at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:152)
          09:51:01 at hudson.plugins.analysis.core.HealthAwareRecorder.perform(HealthAwareRecorder.java:349)
          09:51:01 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          09:51:01 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
          09:51:01 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:734)
          09:51:01 at hudson.model.Build$BuildExecution.post2(Build.java:183)
          09:51:01 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:683)
          09:51:01 at hudson.model.Run.execute(Run.java:1770)
          09:51:01 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          09:51:01 at hudson.model.ResourceController.execute(ResourceController.java:89)
          09:51:01 at hudson.model.Executor.run(Executor.java:240)
          09:51:01 Caused by: java.io.IOException: Remote call on Quick Build Slave for dev failed
          09:51:01 at hudson.remoting.Channel.call(Channel.java:760)
          09:51:01 at hudson.FilePath.act(FilePath.java:969)
          09:51:01 ... 13 more
          09:51:01 Caused by: java.lang.StackOverflowError
          09:51:01 at java.io.ObjectInputStream$BlockDataInputStream.readInt(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readHandle(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readClassDesc(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readObject0(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readSerialData(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readObject0(Unknown Source)
          09:51:01 at java.io.ObjectInputStream.readObject(Unknown Source)
          09:51:01 at java.util.HashSet.readObject(Unknown Source)
          09:51:01 at sun.reflect.GeneratedMethodAccessor465.invoke(Unknown Source)


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              champo Juan Civile
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: