Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14629

plugin don't fail the build when checkout failed

    Details

    • Similar Issues:

      Description

      after a checkout failure, hudson.scm.SubversionSCM#checkout should return false to notify jenkins about the error, but never does

        Attachments

          Issue Links

            Activity

            ndeloof Nicolas De Loof created issue -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nicolas De Loof
            Path:
            src/main/java/hudson/scm/SubversionSCM.java
            src/main/java/hudson/scm/subversion/UpdateUpdater.java
            http://jenkins-ci.org/commit/subversion-plugin/09f17089fdbbfa202735bbd4fc4f0aa241045e64
            Log:
            [FIXED JENKINS-14629] return null to notify about checkout failure
            relates to JENKINS-12201

            kmart216 David Humeniuk added a comment -

            This sounds like a duplicate of an existing issue

            kmart216 David Humeniuk made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-13137 [ JENKINS-13137 ]
            kmart216 David Humeniuk added a comment -

            This issue is included in the changelog for 1.43, but this issue hasn't been updated to reflect

            kutzi kutzi made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            kutzi kutzi made changes -
            Link This issue is duplicated by JENKINS-13055 [ JENKINS-13055 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 145325 ] JNJira + In-Review [ 191433 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                ndeloof Nicolas De Loof
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: