Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14665

Quality center plugin for Hudson does not work properly

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: qc-plugin
    • Labels:
      None
    • Environment:
      Windows Server 2003, Hudson run as windows service
    • Similar Issues:

      Description

      We probably have the same problem as in JENKINS-9459: when starting the test we get the following output. We tried to start the hudson service under different users, but with no luck

      Started by user u_XXXX
      [workspace] $ cscript /nologo "C:\Documents and Settings\u_XXXX\.hudson\jobs\AutoTest\workspace\runTestSet.vbs" http://qc/qcbin/ user ******** CORPORATE XXXX XXX\ XXX1 qcreport-Отладка-18.xml 600 RUN_LOCAL
      02.08.2012 17:00:48 : Script parameters:
      02.08.2012 17:00:48 : *************************************************
      02.08.2012 17:00:48 : QC Server : http://qc/qcbin/
      02.08.2012 17:00:48 : QC UserName : user
      02.08.2012 17:00:48 : QC Password : ********
      02.08.2012 17:00:48 : QC Domain : CORPORATE
      02.08.2012 17:00:48 : QC Project : XXXX
      02.08.2012 17:00:48 : QC TestSetFolder: XXX\
      02.08.2012 17:00:48 : QC TestSetName : XXX1
      02.08.2012 17:00:48 : XML Junit File : qcreport-Отладка-18.xml
      02.08.2012 17:00:48 : Timeout : 600
      02.08.2012 17:00:48 : *************************************************
      02.08.2012 17:00:48 : RunMode : RUN_LOCAL
      02.08.2012 17:00:48 : RunHost : CODEREV
      02.08.2012 17:00:48 : *************************************************
      Connected to server http://qc/qcbin/
      Logged in with user user
      Opened project CORPORATE\XXXX

      --------------------------------------------------------------------------------------------------

      TestSet Name ID

      --------------------------------------------------------------------------------------------------

      XXX1 251

      --------------------------------------------------------------------------------------------------
      Could not instantiate test set scheduler
      Creating report...

      Generating report file
      Report file path: qcreport-Отладка-18.xml

      --------------------------------------------------------------------------------------------------

      Test Name Status

      --------------------------------------------------------------------------------------------------
      Report Created
      FATAL: Couldn't run tests
      [DEBUG] Skipping watched dependency update for build: AutoTest #18 due to result: FAILURE
      Finished: FAILURE

        Attachments

          Activity

          Hide
          daniellemoore Danielle Moore added a comment -

          I am having this same issue. Please provide a solution or suggestion. Thank you!

          Show
          daniellemoore Danielle Moore added a comment - I am having this same issue. Please provide a solution or suggestion. Thank you!
          Hide
          daniellemoore Danielle Moore added a comment -

          This can be resolved! Perform ALM Client registration from QC. This worked for me.

          See this thread:
          http://www.sqaforums.com/showflat.php?Cat=&Board=UBB20&Number=652599

          Answer is from "AnshooArora" at 12/15/10 10:49 AM

          Show
          daniellemoore Danielle Moore added a comment - This can be resolved! Perform ALM Client registration from QC. This worked for me. See this thread: http://www.sqaforums.com/showflat.php?Cat=&Board=UBB20&Number=652599 Answer is from "AnshooArora" at 12/15/10 10:49 AM
          Hide
          chetbani chetbani nadjim added a comment -

          Hi Danielle,

          Firstly thank you for your solution. currently, I have the same problem.

          I use the Jenkins QC plugin since a Windows machine. Since this machine, I lunsh the plugin to execute tests which are on the QC machine (another Windows machine). I would thus like to know on whom of the two machines must I install /perfom ALM Client registration ? on the QC plugin machine or on the QC machine.

          By advance thank you for your answer,

          Regards,

          Show
          chetbani chetbani nadjim added a comment - Hi Danielle, Firstly thank you for your solution. currently, I have the same problem. I use the Jenkins QC plugin since a Windows machine. Since this machine, I lunsh the plugin to execute tests which are on the QC machine (another Windows machine). I would thus like to know on whom of the two machines must I install /perfom ALM Client registration ? on the QC plugin machine or on the QC machine. By advance thank you for your answer, Regards,
          Hide
          daniellemoore Danielle Moore added a comment -

          In my case, it is the same machine. I would perform ALM Client registration on both machines.

          Show
          daniellemoore Danielle Moore added a comment - In my case, it is the same machine. I would perform ALM Client registration on both machines.

            People

            • Assignee:
              danielpetisme Daniel Petisme
              Reporter:
              lakeoffm Max Lake
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: