Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1467

Provide alternate UI for Projects View in the Hudson Main Dashboard

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: Other, OS: Linux
    • Similar Issues:
      Show 5 results

      Description

      if you have many views, the view-names list is very large
      it would be very nice to have the view-names in more than one line

        Attachments

          Issue Links

            Activity

            mindless Alan Harder added a comment -
                • Issue 4910 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment -

            Also see JENKINS-232 which asks for hierarchical views

            huybrechts huybrechts added a comment -

            Like http://hudson.jboss.org/hudson/, implemented by a small change in the CSS.
            Unfortunately it only works in Firefox.

            mindless Alan Harder added a comment -

            FYI, there's now a Nested Views plugin.

            jglick Jesse Glick added a comment -

            Ruins the appearance of: http://hudson.zones.apache.org/hudson/

            wjprakash wjprakash added a comment -

            I have a fix for this issue. The fix is to show the tabs in the side of the table.

            I've added a checkbox [Show Side Tabbar in project views] in global configuration. If selected the tabs will be shown in the side, else regular tab is shown at the top.

            Patch attached

            wjprakash wjprakash added a comment -

            Patch to fix the issue

            wjprakash wjprakash added a comment -

            Based on the community discussion

            Provide option to add additional UI for the the Project View List

            • Multi-line Tab
            • Drop down
            • Side Bar
            • Close-able Single Line Tab with Drop down for remaining views
            • Extension point so that other can add their own view type

            This feature will be developed in a branch and just the extension-point change will go into main/core. Plugins will be be created to add additional UI options.

            Later, if any of the UI option is deemed universally superior, it will replace the current default UI in main, and a plugin or plugins can add to the options to be replaced by the user.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : wjprakash
            Path:
            http://jenkins-ci.org/commit/34934
            Log:
            Branch for fixing JENKINS-1467

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : wjprakash
            Path:
            http://jenkins-ci.org/commit/35827
            Log:
            Init merging of branch JENKINS-1467

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : wjprakash
            Path:
            trunk/hudson/main/core/src/main/java/hudson/Functions.java
            trunk/hudson/main/core/src/main/java/hudson/model/Hudson.java
            trunk/hudson/main/core/src/main/java/hudson/model/MyViewsProperty.java
            trunk/hudson/main/core/src/main/java/hudson/model/TreeView.java
            trunk/hudson/main/core/src/main/java/hudson/model/ViewGroup.java
            trunk/hudson/main/core/src/main/resources/hudson/model/Hudson/configure.jelly
            trunk/hudson/main/core/src/main/resources/hudson/model/View/index.jelly
            trunk/hudson/main/core/src/main/resources/hudson/model/View/main.jelly
            trunk/hudson/main/core/src/main/resources/hudson/model/View/noJob.jelly
            trunk/hudson/main/core/src/main/resources/hudson/views/Messages.properties
            trunk/hudson/main/pom.xml
            trunk/hudson/main/war/pom.xml
            http://jenkins-ci.org/commit/35828
            Log:
            Merging JENKINS-1467

            wjprakash wjprakash added a comment -

            Functionality implemented in version 1.381

            jglick Jesse Glick added a comment -

            "Implemented" but no visible change that I can see in 1.382; I guess users need to install multiline-tabbar-plugin as well? Has a release of this been made yet?

            wjprakash wjprakash added a comment -

            Ah!, I kept the multiline-tabbar-plugin as a bundled plugin, so you'd see the drop down to select different view in Hudson configuration. Looks like Kohsuke moved it in to regular plugins and he didn't mentioned that to me.

            I'm new to Hudson, what should I do to publish a plugin?

            jglick Jesse Glick added a comment -

            Well you need to first remove the code attempting to bundle it from main/war/pom.xml. Then fix the plugin's parent to be ../pom.xml, i.e. trunk/plugins/pom.xml, version 1.381 I suppose, and set a normal version for the plugin such as 1.0-SNAPSHOT. Can probably remove both dependencies since they would be implied by the parent POM, and probably the whole build section too. Then test, and if it seems OK, mvn release:prepare release:perform. Can make a wiki page for the plugin too (pick the correct tag so it is in a sensible category). I can try to help if you are stuck (contact Jesse Glick in people.oraclecorp.com).

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : wjprakash
            Path:
            trunk/www/changelog.html
            http://jenkins-ci.org/commit/36232
            Log:
            Add JENKINS-1467 to change log


              People

              • Assignee:
                wjprakash wjprakash
                Reporter:
                tspengler tspengler
              • Votes:
                4 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: