Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14774

Failed to copy artifacts from another build job with timestamp exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: copyartifact-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.477, copyartifacts 1.22
      Master: Linux
      Slave: Windows XP Pro
    • Similar Issues:

      Description

      We're experiencing the following exception when trying to copy artifacts:

      ERROR: Failed to copy artifacts from PROJECT_1 with filter: deploy/**/*.*
      hudson.util.IOException2: Failed to copy /var/lib/jenkins/jobs/PROJECT_1/builds/2012-04-04_09-44-14/archive/deploy/some_file.txt to c:\jenkins\workspace\PROJECT_2\deploy\some_file.txt
      	at hudson.plugins.copyartifact.FingerprintingCopyMethod.copyOne(FingerprintingCopyMethod.java:91)
      	at hudson.plugins.copyartifact.FingerprintingCopyMethod.copyAll(FingerprintingCopyMethod.java:63)
      	at hudson.plugins.copyartifact.CopyArtifact.perform(CopyArtifact.java:243)
      	at hudson.plugins.copyartifact.CopyArtifact.perform(CopyArtifact.java:215)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717)
      	at hudson.model.Build$BuildExecution.build(Build.java:199)
      	at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:499)
      	at hudson.model.Run.execute(Run.java:1502)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:236)
      Caused by: hudson.util.IOException2: remote file operation failed: c:\jenkins\workspace\PROJECT_2\deploy\some_file.txt at hudson.remoting.Channel@30e16a97:TW-FEQS-XP-LON
      	at hudson.FilePath.act(FilePath.java:838)
      	at hudson.FilePath.act(FilePath.java:824)
      	at hudson.FilePath.touch(FilePath.java:1170)
      	at hudson.plugins.copyartifact.FingerprintingCopyMethod.copyOne(FingerprintingCopyMethod.java:79)
      	... 12 more
      Caused by: java.io.IOException: Failed to set the timestamp of c:\jenkins\workspace\PROJECT_2\deploy\some_file.txt to 1333525392000
      	at hudson.FilePath$19.invoke(FilePath.java:1176)
      	at hudson.FilePath$19.invoke(FilePath.java:1170)
      	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2196)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:287)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at hudson.remoting.Engine$1$1.run(Engine.java:60)
      	at java.lang.Thread.run(Unknown Source)
      Build step 'Copy artifacts from another project' marked build as failure
      

      We followed the workaround mentioned in issue 9456. Be aware that the master is a Linux machine and the slave is Windows.

        Attachments

          Issue Links

            Activity

            ikedam ikedam added a comment -

            It looks caused by a file permission problem.
            Please check followings:

            • On whose authorization Jenkins runs.
            • Who owes deploy and some_file.txt

            And it may be resolved by deleting the deploy directory at the beginning of a build. Please try that.

            ikedam ikedam added a comment -

            Looks a duplicate of JENKINS-13515.
            It is fixed in 1.24.


              People

              • Assignee:
                mindless Alan Harder
                Reporter:
                desolat Christoph Jaehnigen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: