Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14911

Triggered Build does not stop for Parameters

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I'm using the Parametrized Trigger Plugin. I go into the build and add the action "Trigger parametrized build on other projects". The other "Project" (i.e. the deploy job) appears to execute. However it does not stop and ask for the Parameters that are setup. (Choice, extended choice, etc.). If I execute the deploy job with "Build Now", it will in fact stop for parameters.

        Attachments

          Activity

          Hide
          cjo9900 cjo9900 added a comment -

          The Parametrized Trigger Plugin is used to pass parameters from one job to another there is no prompting for parameters as there is no user interaction at this point.

          So if you downstream job has parameters you need to pass all of these from the upstream job, using one of the options for creating the parameters. Note the missing parameters are not used or set to the defaults.

          If you want the default values for the downstream job there is no need to trigger the job with parameters as these will be added automatically.

          Show
          cjo9900 cjo9900 added a comment - The Parametrized Trigger Plugin is used to pass parameters from one job to another there is no prompting for parameters as there is no user interaction at this point. So if you downstream job has parameters you need to pass all of these from the upstream job, using one of the options for creating the parameters. Note the missing parameters are not used or set to the defaults. If you want the default values for the downstream job there is no need to trigger the job with parameters as these will be added automatically.
          Hide
          nateo Nathan Overbey added a comment -

          The original issue is no longer needed but the issue in the comment still exists. Opening a separate case for that.

          Show
          nateo Nathan Overbey added a comment - The original issue is no longer needed but the issue in the comment still exists. Opening a separate case for that.
          Hide
          nateo Nathan Overbey added a comment -

          Also, after fiddling with the projects so no new jobs will promote properly. My Jenkins is in a really bad state now. I've noticed bad things happen when trying to promote a old build with a build promotion process that has been deleted. (the promotion process stays behind on old builds). Any suggestions on how to fix it without rebuilding my jenkins install?

          Show
          nateo Nathan Overbey added a comment - Also, after fiddling with the projects so no new jobs will promote properly. My Jenkins is in a really bad state now. I've noticed bad things happen when trying to promote a old build with a build promotion process that has been deleted. (the promotion process stays behind on old builds). Any suggestions on how to fix it without rebuilding my jenkins install?

            People

            • Assignee:
              huybrechts huybrechts
              Reporter:
              nateo Nathan Overbey
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: