Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14947

Build fail from UnsupportedOperationException during Doxygen post-build step

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: doxygen-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Transitioning job from system with older version of Jenkins to newer version of Jenkins; build slave is the same.

      Get the following error when trying to run the job on newer Jenkins:

      Publishing Doxygen HTML results.
      The determined Doxygen directory is '/usr/drbuild/workspace/product/build/html'.
      FATAL: error
      hudson.util.IOException2: java.lang.UnsupportedOperationException
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1784)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1676)
      at hudson.plugins.doxygen.DoxygenArchiver._perform(DoxygenArchiver.java:231)
      at hudson.plugins.doxygen.DoxygenArchiver.perform(DoxygenArchiver.java:176)
      at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:710)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:685)
      at hudson.model.Build$RunnerImpl.post2(Build.java:162)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:632)
      at hudson.model.Run.run(Run.java:1463)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:239)
      Caused by: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
      at hudson.remoting.Channel$4.adapt(Channel.java:696)
      at hudson.remoting.Channel$4.adapt(Channel.java:691)
      at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
      at hudson.FilePath.copyRecursiveTo(FilePath.java:1782)
      ... 12 more
      Caused by: java.lang.UnsupportedOperationException
      at hudson.os.PosixAPI$1.getCurrentWorkingDirectory(PosixAPI.java:59)
      at org.jruby.ext.posix.util.ExecIt.run(ExecIt.java:59)
      at org.jruby.ext.posix.util.ExecIt.runAndWait(ExecIt.java:51)
      at org.jruby.ext.posix.JavaLibCHelper.readlink(JavaLibCHelper.java:196)
      at org.jruby.ext.posix.JavaPOSIX.readlink(JavaPOSIX.java:160)
      at hudson.Util.resolveSymlink(Util.java:1067)
      at hudson.Util.resolveSymlink(Util.java:1030)
      at hudson.util.DirScanner$Glob.scan(DirScanner.java:115)
      at hudson.FilePath.writeToTar(FilePath.java:1820)
      at hudson.FilePath.access$1000(FilePath.java:166)
      at hudson.FilePath$36.invoke(FilePath.java:1761)
      at hudson.FilePath$36.invoke(FilePath.java:1758)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2193)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:636)
      Build step 'Publish Doxygen' changed build result to FAILURE

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            This was already fixed:

            May 22, 2012 9:43:45 PM	95c1728	Kohsuke Kawaguchi <kk@kohsuke.org>	[FIXED JENKINS-13202] fixed a regression in untar on exotic platforms.
            
            Fall back in non-JNA case wasn't working.
            

              People

              • Assignee:
                gbois Gregory Boissinot
                Reporter:
                lars_nordin lars Nordin
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: