Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15011

Jacoco Plugin 1.0.3 - no threshold config and displays broken graphic link

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: jacoco-plugin
    • Labels:
      None
    • Environment:
      Windows Server 2008 SP2, Apache Tomcat 7.0.22
    • Similar Issues:

      Description

      After installing the new version, 1.0.3, several issues are now occurring:
      1. There's no longer coverage threshold settings fields in the project configuration.
      2. The Jacoco Coverage Report for the build displays a broken graphic.
      3. The Jacoco Coverage Trend doesn't display any data.

      See attached screen prints for more information.

        Attachments

          Issue Links

            Activity

            hmlnarik H Mlnarik added a comment -

            The issue is also present in version 1.0.8 of JaCoCo plugin.

            ognjenb Ognjen Bubalo added a comment -

            Hi,

            This would be the next issue to fix.

            ogi

            smceneaney Shane McEneaney added a comment -

            Hi Ogi,

            This looks like the same problem I have. Has this been fixed yet?

            Thanks,

            Shane

            ognjenb Ognjen Bubalo added a comment -

            Hi,

            If you create a new job of your project you should have a good graph. This is a workaround of course. I'll fix it. The main problem is that the plugin was completely refactored, so it is hard to put back the old serialized fields properly.

            I did not start to work on the threshold feature. It won't take too much time to implment. Currently I'm working on the inclusions, exclusions feature.

            Cheers,
            Ogi


              People

              • Assignee:
                ognjenb Ognjen Bubalo
                Reporter:
                drothauser Doug Rothauser
              • Votes:
                2 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: