Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15057

Manual plugin upload should download plugin dependencies

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Linux
    • Similar Issues:

      Description

      When manually uploading a plugin X (Manage Plugins -> Advanced -> Upload Plugin) Jenkins does not automatically install plugins which X depends on, unlike with the regular plugin installation from the catalog (Manage Plugins -> Available).

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Probably, the issue should be closed with the "as designed" status.
          BTW, a notification in UI would be useful

          danielbeck Daniel Beck added a comment -

          I disagree. With dynamic loading enabled, it really attempts to behave as update center installation.

          This behavior should be changed, and downloading only not happen when the appropriate .never system property is set (i.e. Jenkins in offline mode).

          Still, not a bug.

          slide_o_mix Alex Earl added a comment -
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Daniel Beck
          Path:
          core/src/main/java/hudson/PluginManager.java
          test/src/test/java/hudson/PluginManagerTest.java
          test/src/test/resources/plugins/Parameterized-Remote-Trigger.hpi
          test/src/test/resources/plugins/credentials.hpi
          test/src/test/resources/plugins/icon-shim.hpi
          test/src/test/resources/plugins/token-macro.hpi
          test/src/test/resources/plugins/upload-test-update-center.json
          http://jenkins-ci.org/commit/jenkins/d5c508dece359f22799acaf84830be9e3a9e2ec3
          Log:
          Merge pull request #2239 from slide/master

          [FIXED JENKINS-15057] Add dependency resolution to manually uploaded plugins.

          Compare: https://github.com/jenkinsci/jenkins/compare/274183dba2bc...d5c508dece35

          janek Jan Molak added a comment -

          Awesome, good job Daniel Beck! This will make automated testing of Jenkins plugins much easier

          danielbeck Daniel Beck added a comment -

          Jan Molak: Alex Earl deserves all your praise, I just managed to click a giant green button on GitHub.

          janek Jan Molak added a comment -

          Alex Earl, Daniel Beck - thanks guys, you rock!


            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              m2spring Max Spring
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: