Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1517

SVNkit "svn: Network connection closed unexpectedly"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Due to new svnkit in Hudson, we've stucked with update failures on some node
      (debian).
      It looks like this:
      ======================
      started
      Building remotely on deb4 APS catalog
      Updating svn://ofsvn.plesk.ru:3693/apscatalog/trunk
      ERROR: Failed to update svn://ofsvn.plesk.ru:3693/apscatalog/trunk
      org.tmatesoft.svn.core.SVNException: svn: Network connection closed unexpectedly
      at
      org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:55)
      at
      org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:40)
      at
      org.tmatesoft.svn.core.internal.io.svn.SVNReader.readChar(SVNReader.java:559)
      at
      org.tmatesoft.svn.core.internal.io.svn.SVNReader.parse(SVNReader.java:293)
      at
      org.tmatesoft.svn.core.internal.io.svn.SVNConnection.handshake(SVNConnection.java:103)
      at
      org.tmatesoft.svn.core.internal.io.svn.SVNConnection.open(SVNConnection.java:62)
      at
      org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.openConnection(SVNRepositoryImpl.java:974)
      at
      org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getDatedRevision(SVNRepositoryImpl.java:159)
      at
      org.tmatesoft.svn.core.wc.SVNBasicClient.getRevisionNumber(SVNBasicClient.java:346)
      at
      org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:159)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:382)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:354)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1093)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:200)
      at
      java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      ======================

      however, executing the same 'svn up' command with shell on the node works well.
      I have no idea about the reasons for now, cos other nodes does not fail (with
      same SVN version there). I had to downgrade Hudson to 1.201 - everything goes
      fine.

      More info:

      SVN version:
      ===========
      >svn --version
      svn, version 1.4.2 (r22196)
      compiled Nov 10 2006, 17:39:50
      ===========

      Hudson version: 1.204

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Could it be that this happens under the heavy load or something? How do you run
          the server? Is it throttling the # of concurrent connections by any chance?

          I wonder if you could run a tool like Wireshark to see what goes across the wire?

          jazzjack jazzjack added a comment -

          nope, it isn't loded either, almost idle. command running slave is:
          > ssh builder@<ip_addr> java -jar slave.jar

          there is no display there, so i tried to use tcpdump. SVN traffic is encrypted,
          so there is no way to see packet contents. the only i could see is headers:

          13:03:49.416319 IP deb31php5-test.sbvz.plesk.ru.39067 > cvs2.plesk.ru.3693: S
          4037988511:4037988511(0) win 5840 <mss 1460,sackOK,timestamp 216571785
          0,nop,wscale 7>
          13:03:49.416493 IP cvs2.plesk.ru.3693 > deb31php5-test.sbvz.plesk.ru.39067: S
          3777855448:3777855448(0) ack 4037988512 win 65535 <mss 1460,nop,wscale
          1,nop,nop,timestamp 605136388 216571785,nop,nop,sackOK>
          13:03:49.416507 IP deb31php5-test.sbvz.plesk.ru.39067 > cvs2.plesk.ru.3693: .
          ack 1 win 46 <nop,nop,timestamp 216571785 605136388>
          13:03:49.443407 IP cvs2.plesk.ru.3693 > deb31php5-test.sbvz.plesk.ru.39067: .
          1:47(46) ack 1 win 33000 <nop,nop,timestamp 605136390 216571785>
          13:03:49.443451 IP deb31php5-test.sbvz.plesk.ru.39067 > cvs2.plesk.ru.3693: .
          ack 47 win 46 <nop,nop,timestamp 216571812 605136390>
          13:03:49.443689 IP cvs2.plesk.ru.3693 > deb31php5-test.sbvz.plesk.ru.39067: P
          47:53(6) ack 1 win 33000 <nop,nop,timestamp 605136390 216571812>
          13:03:49.443715 IP deb31php5-test.sbvz.plesk.ru.39067 > cvs2.plesk.ru.3693: .
          ack 53 win 46 <nop,nop,timestamp 216571813 605136390>
          13:03:49.443901 IP deb31php5-test.sbvz.plesk.ru.39067 > cvs2.plesk.ru.3693: R
          1:1(0) ack 53 win 46 <nop,nop,timestamp 216571813 605136390>

          I've tried to use SVN with HTTP and it works. so likely the problem somewhere
          in svn+ssh implementation...

          kohsuke Kohsuke Kawaguchi added a comment -

          I'm not sure how to read tcpdump console output, but if anyone experiencing this
          issue can send me the tcpdump output, I can load it in Wireshark and examine
          what's going on.


            People

            • Assignee:
              Unassigned
              Reporter:
              jazzjack jazzjack
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: