Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15322

NOTESTS in TAP response gives parse error and stack trace from plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: tap-plugin
    • Labels:
    • Environment:
      centos 6
    • Similar Issues:

      Description

      A .tap file containing a NOTESTS result (from eg a skip_all declaration in a .t file) such as

      /opt/performance/scripts/t/dbcoststest1.t .. skipped: No Relevant Tests as No DB Costs for GetSmoidTrackV11New
      Files=1, Tests=0,  1 wallclock secs ( 0.01 usr  0.02 sys +  0.54 cusr  0.04 csys =  0.61 CPU)
      Result: NOTESTS
      

      results in the following errors when running a plan from Jenkins:

      Parsing TAP test result [/var/lib/jenkins/jobs/Performance-Server-Trunk/builds/2012-09-26_16-06-21/tap/dbcostsGetSmoidTrackV11New.tap].
      org.tap4j.parser.ParserException: Error parsing TAP Stream: Missing TAP Plan.
      	at org.tap4j.parser.Tap13YamlParser.parseFile(Tap13YamlParser.java:587)
      	at org.tap4j.plugin.TapParser.parse(TapParser.java:94)
      	at org.tap4j.plugin.TapPublisher.loadResults(TapPublisher.java:240)
      	at org.tap4j.plugin.TapPublisher.perform(TapPublisher.java:182)
      	at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:705)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:680)
      	at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:996)
      	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:627)
      	at hudson.model.Run.run(Run.java:1438)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:238)
      Caused by: org.tap4j.parser.ParserException: Missing TAP Plan.
      	at org.tap4j.parser.Tap13YamlParser.checkTAPPlanIsSet(Tap13YamlParser.java:353)
      	at org.tap4j.parser.Tap13YamlParser.postProcess(Tap13YamlParser.java:736)
      	at org.tap4j.parser.Tap13YamlParser.parseFile(Tap13YamlParser.java:585)
      	... 12 more
      

        Attachments

          Issue Links

            Activity

            kinow Bruno P. Kinoshita added a comment -

            Fixed in 1.10

            kinow Bruno P. Kinoshita added a comment -

            Fixed. Will release in 2.0 with JENKINS-17245.

            kinow Bruno P. Kinoshita added a comment -

            Wiki updated. Created the section "Running Perl tests with prove" with an example of how one can run prove and archive its output. The procedure is the same even if you use NOTESTS in TAP.

            You can follow the instructions there, but there's another bug which causes the plug-in to not list tests which plan is marked as skip all. The remaining work will continue there, please feel free to comment there.

            Both issues will be released together in 2.0.

            kinow Bruno P. Kinoshita added a comment -

            The link to the bug fixed in tap4j: https://github.com/tupilabs/tap4j/issues/13

            kinow Bruno P. Kinoshita added a comment -

            Yay! There are some broken links, and seems like they had to restore an old backup. I'll add tap4j information and examples there again.

            As a side note, I believe I've fixed this issue, but as I had to fix tap4j parser, I'll use a few more hours to test it.

            I'll update the Wiki with information on how to use the plug-in with prove --archive and an example with skip_all.


              People

              • Assignee:
                kinow Bruno P. Kinoshita
                Reporter:
                alex_n Alex Newnham
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: