Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15518

Jenkins Cobertura-1.7 fails to get the coverage result

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Environment:
      Jenkins-1.466.2, Cobertura-1.7
    • Similar Issues:

      Description

      Get following error message with Cobertura-1.7 version. Downgrade to 1.5 works fine.

      Publishing Cobertura coverage report...
      FATAL: Unable to find coverage results
      hudson.util.IOException2: remote file operation failed: /home/jenkins/squeeze-amd64/workspace/trogdor/arch/amd64/dist/Debian-6.0 at hudson.remoting.Channel@2c3525fc:seblddev-debian-squeeze-amd64
      at hudson.FilePath.act(FilePath.java:835)
      at hudson.FilePath.act(FilePath.java:821)
      at hudson.plugins.cobertura.CoberturaPublisher.perform(CoberturaPublisher.java:335)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:710)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:685)
      at hudson.model.Build$RunnerImpl.post2(Build.java:162)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:632)
      at hudson.model.Run.run(Run.java:1463)
      at hudson.matrix.MatrixRun.run(MatrixRun.java:146)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:239)
      Caused by: java.io.IOException: Unable to serialize hudson.FilePath$FileCallableWrapper@7dc8e850
      at hudson.remoting.UserRequest.serialize(UserRequest.java:166)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:62)
      at hudson.remoting.Channel.call(Channel.java:662)
      at hudson.FilePath.act(FilePath.java:828)
      ... 11 more
      Caused by: java.io.NotSerializableException: hudson.plugins.cobertura.CoberturaPublisher
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1180)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
      at hudson.remoting.UserRequest._serialize(UserRequest.java:155)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:164)
      ... 14 more

        Attachments

          Activity

          rbaradari Ramin Baradari added a comment -

          A patch is available for merge in this pull request:
          https://github.com/jenkinsci/cobertura-plugin/pull/10

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: r.baradari
          Path:
          src/main/java/hudson/plugins/cobertura/CoberturaPublisher.java
          http://jenkins-ci.org/commit/cobertura-plugin/2e2f3b0568c4cc4ee235fc98d494a0b085f0bf67
          Log:
          JENKINS-15518 changed anonymous inner FileCallable to nested class because the outer class is not serializable

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Nicolas De loof
          Path:
          src/main/java/hudson/plugins/cobertura/CoberturaPublisher.java
          http://jenkins-ci.org/commit/cobertura-plugin/e2777e8d795ae863ef24832bf23ad6b7c2ef490f
          Log:
          Merge pull request #10 from rbaradari/fix-15518

          JENKINS-15518 changed anonymous inner FileCallable to nested class because the outer class is not serializable

          Compare: https://github.com/jenkinsci/cobertura-plugin/compare/9e6a61b3048a...e2777e8d795a

          jglick Jesse Glick added a comment -

          Committed in 1.7.1, right?

          ndeloof Nicolas De Loof added a comment -

          indeed, fixed in 1.7.1

          liya Liya Katz added a comment -

          Got this error after upgrade to 1.8

          jglick Jesse Glick added a comment -

          @liya please show the exact error message you now get, so developers can confirm that you are really running 1.8, and that the error is really the same.

          liya Liya Katz added a comment -

          [Cobertura] Publishing Cobertura coverage report...
          FATAL: Unable to find coverage results
          java.io.IOException: /opt/jenkins/jobs/xxx/workspace/xxx/xxx/target/coverage/index.html is not a cobertura coverage report, please check your report pattern
          at hudson.plugins.cobertura.CoberturaPublisher$ParseReportCallable.invoke(CoberturaPublisher.java:546)
          at hudson.plugins.cobertura.CoberturaPublisher$ParseReportCallable.invoke(CoberturaPublisher.java:519)
          at hudson.FilePath.act(FilePath.java:865)
          at hudson.FilePath.act(FilePath.java:838)
          at hudson.plugins.cobertura.CoberturaPublisher.perform(CoberturaPublisher.java:337)
          at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:814)
          at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:786)
          at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:947)
          at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:733)
          at hudson.model.Run.execute(Run.java:1592)
          at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:237)
          [Cobertura] No coverage results were found using the pattern '**/target/coverage/index.html' relative to '/opt/jenkins/jobs/xxx/workspace'. Did you enter a pattern relative to the correct directory? Did you generate the XML report(s) for Cobertura?
          [Cobertura] Skipped cobertura reports.
          Build step 'Publish Cobertura Coverage Report' changed build result to FAILURE

          liya Liya Katz added a comment -

          needless to say that the /opt/jenkins/jobs/xxx/workspace/xxx/xxx/target/coverage/index.html exists..

          liya Liya Katz added a comment -

          Downgrading to 1.7.1 has solved the problem

          sogabe sogabe added a comment -

          The coverage/index.html is an html style report, not xml style one. You have to specify xml style report like a coverage.xml in "Cobertura xml report pattern".

          sogabe sogabe added a comment -

          No response.


            People

            • Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              kevincai Kevin Cai
            • Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: