Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15634

Ignore aborted builds in age calculation for failing tests

    Details

    • Similar Issues:

      Description

      When test fails in one build, then the second build is aborted - in the third one the age of a testcase failure will be 1 instead of 3 (example test could not be executed). In big projects with thousands of tests it is hard to determine the reason of failure in such situations as above. All the test results history is corrupted.

      Maybe It is a good idea to ignore aborted builds in age calculation.

        Attachments

          Activity

          nvrfrgt Kamil Janyga created issue -
          nvrfrgt Kamil Janyga made changes -
          Field Original Value New Value
          Assignee Kamil Janyga [ nvrfrgt ]
          nvrfrgt Kamil Janyga made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          nvrfrgt Kamil Janyga added a comment -

          Pull request created.

          nvrfrgt Kamil Janyga made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          nvrfrgt Kamil Janyga made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          tomaszbech Tomasz Bech added a comment -

          It looks like regression.
          We are using 'Publish junit test result report'.

          After broken build all failed tests' AGE is reset to 1.

          Jenkins 1.596, but the problem was observed for over a year.

          In 'Build' section ant scritps are used.

          tomaszbech Tomasz Bech made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Assignee Kamil Janyga [ nvrfrgt ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 146390 ] JNJira + In-Review [ 186089 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              nvrfrgt Kamil Janyga
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: