Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15676

Self-Polling Recommendation and Description - our case 8515

    Details

    • Similar Issues:

      Description

      From Iosif Neitzke:

      We're using version 1.2.0 of the Clearcase UCM Plugin for Jenkins, and
      we've noticed it doesn't seem to recommend baselines or set a build
      description when set to self-poll streams at promotion level ANY. Is
      this by design?

        Attachments

          Activity

          wolfgang Christian Wolfgang created issue -
          wolfgang Christian Wolfgang added a comment -

          Ok, it's by design. Actually, when creating the ANY feature, we didn't really know its exact usecase. We wanted a feature that mimicked the Git plugin, SVN plugin and so on, in terms of not processing all the baselines in turn. Since it wasn't obvious how the found baseline should be processed after the build step, we disabled the entire post build step. That is, disabling promotion, recommendation, description and so on.

          You are the first one to question this feature! How should the post build step be? You want to be able to recommend a baseline and describe the build. But what about the promotion level? Should that be changed?

          vorathis Michael Davenport added a comment -

          I feel like if you select "ANY" for the promotion level, you are claiming that you don't want the plugin to deal with promotion levels. I would expect that recommendation and description would continue, but promotion would not.

          iosif_neitzke Iosif Neitzke added a comment -

          I think when set to Self-Poll with promotion level "ANY" (which is a sort of complicated way of saying "just use the most recent baseline on the stream for the build, regardless of its promotion level"), the plugin would, when Description and Recommend options are checked, post the baseline used as the job description, and recommend that same baseline if the job succeeded. If the Tag option is checked, the tag always could be set, but the tag might need updating if the same baseline is built more than once.

          I suppose that like Mr Davenport suggests for the "ANY" promotion option, the baseline promotion level would be left as it is, regardless of job success or failure.

          wolfgang Christian Wolfgang added a comment -

          Thank you for your feedback. It will definitely be implemented that way in the next release.

          It would be of great help if you signed up for our registered user program at http://www.praqma.com/resources/signup, that way we can fine tune the plugin even more with your feedback and input.

          You could help us even further by sharing your usage scenario at https://wiki.jenkins-ci.org/display/JENKINS/ClearCase+UCM+Plugin+Usage

          jbrejner Jens Brejner made changes -
          Field Original Value New Value
          Assignee Christian Wolfgang [ wolfgang ] Praqma Support [ praqma ]
          jbrejner Jens Brejner added a comment -

          pseudo-linking to our internal tracker

          jbrejner Jens Brejner made changes -
          Summary Self-Polling Recommendation and Description Self-Polling Recommendation and Description - our case 8515
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christian Wolfgang
          Path:
          src/main/java/net/praqma/hudson/notifier/RemotePostBuild.java
          http://jenkins-ci.org/commit/clearcase-ucm-plugin/7d2f4086820fcb07d288981274eacaf33d9b1ef5
          Log:
          [fixed JENKINS-15676] Finalizing

          Compare: https://github.com/jenkinsci/clearcase-ucm-plugin/compare/a612352e21f8...7d2f4086820f


          You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
          For more options, visit https://groups.google.com/groups/opt_out.

          scm_issue_link SCM/JIRA link daemon made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 146432 ] JNJira + In-Review [ 191933 ]

            People

            • Assignee:
              praqma Praqma Support
              Reporter:
              wolfgang Christian Wolfgang
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: