Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15719

Builds and workspace disappear for jobs created after upgrade to 1.487

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.487 on RHEL5 x86_64
    • Similar Issues:

      Description

      Recreated from comment in JENKINS-15335: Every new job created post 1.487 have their builds and workspace disappearing on the UI. Reverted to release 1.486 and all builds and workspace are visible.

      I have observed the same issue for a job that was created as well as for the job being renamed after upgrade. Again, reverting to 1.486 caused the issue to go away.

      Note that all builds (run both before upgrade and after upgrade) are recorded in JENKINS_HOME and showed up after reverting to 1.486.

      Jobs that were not renamed or created after upgrade were not affected.

        Attachments

          Issue Links

            Activity

            raspy Krzysztof Malinowski added a comment -

            It was reported there but seems to be a different issue.

            vijay_sfdc vijay singh added a comment -

            Krzysztof - Thanks for logging it on my behalf.

            tomfanning Tom Fanning added a comment -

            I think we may be suffering from the same issue. We see the above, but also on projects that have never been renamed. It also affects promotion logs (404 when link clicked).

            Restarting Jenkins makes it all better for us.

            nickolayr Nickolay Rumyantsev added a comment -

            Hi,

            I have a Jenkins 1.512 workins on the RHEL 5.3 machine.
            I had a job that worked normally. Once I renamed it.
            After that everyday at 16.27 EDT all builds disapper from this job.
            The jenkins log contains nothing like "couldn't load the job" about this job, only records like "Job build SUCCESS" or "Job build FAILURE".
            The job is configured to run at 16.30 everyday so I thought it is the clue but changes to the schedule doesn't affect the situation.
            I also tried to enable/disable different strategies of builds discarding - nothing helps.
            All the builds data remain in the filesystem so the restart helps (all the builds are shown like all is ok) but only until 16.27.
            There is another job that starts at the 16.30 and it is ok.

            danielbeck Daniel Beck added a comment -

            There have been several fixes to this since this was reported (+ last updated), so resolving as Cannot Reproduce.

            Please file a new bug report if this still occurs on a recent version of Jenkins (no older than eight weeks). Include as much information as you can.


              People

              • Assignee:
                Unassigned
                Reporter:
                raspy Krzysztof Malinowski
              • Votes:
                17 Vote for this issue
                Watchers:
                19 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: