Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16098

Nested View Plugin shows FAIL build staus whenever Build Pipeline Plugin is used as a Nested View

    Details

    • Similar Issues:

      Description

      Always shows fail whenever we use a build pipeline as a nested view. Even if there is no issues in the build pipeline.

      Moreover, it is impossible to add a nested view if the first one is a build pipeline.

        Attachments

          Issue Links

            Activity

            fbrubbo Fernando Rubbo created issue -
            marc_guenther Marc Günther added a comment - - edited

            That's interesting, for me, the nested view always shows the grey "ABORTED" status.

            marc_guenther Marc Günther added a comment -

            BTW, you should probably report your second statement: "Moreover, it is impossible..." as a separate issue.

            yoichi Yoichi Nakayama added a comment -

            >Always shows fail whenever we use a build pipeline as a nested view. Even if there is no issues in the build pipeline.

            NestedView shows worst status within BuildPipelineView.getItems().

            BuildPipelineView.java
                @Override
                public Collection<TopLevelItem> getItems() {
                    return Hudson.getInstance().getItems();
                }
            
            yoichi Yoichi Nakayama made changes -
            Field Original Value New Value
            Assignee Yoichi Nakayama [ yoichi ]
            yoichi Yoichi Nakayama added a comment - - edited

            >Always shows fail whenever we use a build pipeline as a nested view. Even if there is no issues in the build pipeline.

            fixed in build-pipeline-plugin-1.4.2
            https://github.com/jenkinsci/build-pipeline-plugin/pull/17

            yoichi Yoichi Nakayama made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            yoichi Yoichi Nakayama added a comment -

            >Moreover, it is impossible to add a nested view if the first one is a build pipeline.

            I could not reproduce the problem.
            Please report with detailed procedure as another issue, if the problem remains.

            yoichi Yoichi Nakayama made changes -
            Assignee Yoichi Nakayama [ yoichi ] Fernando Rubbo [ fbrubbo ]
            marc_guenther Marc Günther added a comment -

            Thanks Yoichi, that looks great!

            yoichi Yoichi Nakayama made changes -
            Link This issue is related to JENKINS-16748 [ JENKINS-16748 ]
            midikem Anders Nyström added a comment -

            Still have some problems with this fix! It looks great if you have just one pipeline! But if you have multiple pipelines that uses the same builds (except the starting build off course) then this is a problem still. The thing that happens when one build fails in one of your pipelines is that all your pipelines get red! This ain't good at all! The goal here should be to only get the pipeline red or green that fails or succeeds at the moment! Don't know how to solve that though!

            killdash9 Michael Andrews added a comment -

            This is still not fixed. As stated, if one job in one pipeline is red - ALL pipeline views are red. This is really bad. Can we reopen?

            killdash9 Michael Andrews added a comment - - edited

            To reproduce - create two pipelines (each with different jobs). Create two Build Pipeline views. Add the "Status" Ball to each view. Break a job in one view, and both views are red. v1.5.1

            killdash9 Michael Andrews added a comment -

            Reopening (hope that is ok). See comments.

            killdash9 Michael Andrews made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 146902 ] JNJira + In-Review [ 186101 ]

              People

              • Assignee:
                fbrubbo Fernando Rubbo
                Reporter:
                fbrubbo Fernando Rubbo
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated: