Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16117

sporadical unwanted suppression of build artifacts

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      Debian Squeeze
    • Similar Issues:

      Description

      Some build jobs regularly loose all their build artifacts.
      Then everything becomes as if these jobs have never been run before.
      This make depending projects (using copy-artifacts) fail.

      Such jobs have "Discard old builds" and "Max # of builds to keep" set.
      This occurs only for a few weeks, so this may be a regression.
      Currently affected version is 1.492

      There is no obvious raison in which situation the artifacts get deleted.
      This can occur even if the be job is not run (e.g. nothing been committed)
      This began to occur shortly (but not immediately) after I started creating multi-configuration jobs.
      This can affect both multi-configuration and/or freestyle projects.

        Attachments

          Issue Links

            Activity

            aeschbacher aeschbacher created issue -
            aeschbacher aeschbacher made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-15156 [ JENKINS-15156 ]
            danielbeck Daniel Beck added a comment -

            Needs to be reproduced in recent Jenkins version due to several issues related to lazy loading having been resolved in the mean time (e.g. builds were known disappear for jobs that have been renamed since Jenkins was started). 1.532.3 would be a good start, or 1.554 and up.

            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Cannot Reproduce [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 146921 ] JNJira + In-Review [ 192141 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                aeschbacher aeschbacher
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: