Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16161

Can't Install Plugin - - Malicious Code - FTP Download deleted

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: pmd-plugin
    • Labels:
      None
    • Environment:
      WinXP
      with Jenkins 1.493 and 1.494
    • Similar Issues:

      Description

      Getting this error when trying to install plugin:
      PMD Plugin
      Failure -
      hudson.util.IOException2: Failed to download from http://updates.jenkins-ci.org/download/plugins/pmd/3.33/pmd.hpi
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:741)
      at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1078)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1240)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1056)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: Inconsistent file length: expected 7867436 but only got 4716722
      at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:736)
      ... 9 more

      THEN tried to go to the FTP URL and got this error:

      Restricted URL

      A malicious code was detected in your web traffic:

      Item: http://mirror.xmission.com/jenkins/plugins/pmd/3.33/pmd.hpi
      Action: deleted

      Infection detail:

      – File: pmd.hpi, malicious code name: Exceed_Compression_Ratio_Limit
      The uncleanable file was deleted.

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          I don't think that this is a defect that I can fix. There is something broken in the mirror that hosts the artifact. (Or a proxy that sits in between).


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              damiensaunders Damien Saunders
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: