Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16270

Build metrics icon filename incorrect

    Details

    • Similar Issues:

      Description

      The build metrics icon is called icons/build-metrics.PNG, however the link used in the management page references icons/build-metrics.png. This works on Windows where filenames are case insensitive, but will not work on Unix.

      There doesn't seem to be a build-metrics component in JIRA, so I've set it to plugin instead, I hope this is okay.
      [[Shannon]] Found the build-metrics component and adjusted the ticket.

        Attachments

          Activity

          jamiep Jamie Penman-Smithson created issue -
          kerrhome Shannon Kerr made changes -
          Field Original Value New Value
          Labels plugin build-metrics plugin
          Description The build metrics icon is called {{icons/build-metrics.*PNG*}}, however the link used in the management page references {{icons/build-metrics.*png*}}. This works on Windows where filenames are case insensitive, but will not work on Unix.

          There doesn't seem to be a {{build-metrics}} component in JIRA, so I've set it to {{plugin}} instead, I hope this is okay.
          The build metrics icon is called {{icons/build-metrics.*PNG*}}, however the link used in the management page references {{icons/build-metrics.*png*}}. This works on Windows where filenames are case insensitive, but will not work on Unix.

          There doesn't seem to be a {{build-metrics}} component in JIRA, so I've set it to {{plugin}} instead, I hope this is okay.
          [[Shannon]] Found the build-metrics component and adjusted the ticket.
          Component/s build-metrics [ 17545 ]
          Component/s plugin [ 15491 ]
          kerrhome Shannon Kerr added a comment -

          To get around this bug until it is fixed, you can do this on systems that use the Debian Package Manager (I'm using Ubuntu 12.04):

          sudo dpkg-divert --divert /var/lib/jenkins/plugins/build-metrics/icons/build-metrics.png --rename /var/lib/jenkins/plugins/build-metrics/icons/build-metrics.PNG

          to revert once the issue is fixed:

          dpkg-divert --rename --remove /var/lib/jenkins/plugins/build-metrics/icons/build-metrics.PNG

          kerrhome Shannon Kerr added a comment -

          Hi Maddy, are you still supporting this plugin?

          kerrhome Shannon Kerr made changes -
          Assignee Maddy Goss [ javamllama ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 147084 ] JNJira + In-Review [ 176804 ]
          px3 Rolf Rother made changes -
          Assignee Maddy Goss [ javamllama ] Rolf Rother [ px3 ]
          px3 Rolf Rother added a comment -

          Fixed. and will be included in the next release

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Rolf Rother
          Path:
          src/main/webapp/icons/build-metrics.PNG
          src/main/webapp/icons/build-metrics.png
          http://jenkins-ci.org/commit/build-metrics-plugin/d7b6838706ad2398505ca00174f54f4a582b1eb0
          Log:
          [FIXED JENKINS-16270] Fixed filename from PNG to png

          scm_issue_link SCM/JIRA link daemon made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]

            People

            • Assignee:
              px3 Rolf Rother
              Reporter:
              jamiep Jamie Penman-Smithson
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: