Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16296

Sometimes commits that mix property changes and text changes do not cause project to be triggered

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      subversion-plugin 1.44
    • Similar Issues:

      Description

      JENKINS-14685 does not cover all situations (i.e. there was a test-case missing).

      Testcase test only combined adding of files and property changes, but not file modification and property changes.

      I have added the missing test case (which now fails) and look for a fix.

        Attachments

          Issue Links

            Activity

            paux Stephan Pauxberger created issue -
            paux Stephan Pauxberger made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-14685 [ JENKINS-14685 ]
            paux Stephan Pauxberger added a comment -

            Actually, the changed tests does NOT reproduce this behaviour (nontheless the test were not complete).

            paux Stephan Pauxberger added a comment -

            Actually, the problem was caused by a wrong post-commit hook (Argument List to long), however I will create a pull request for the corrected test case.

            paux Stephan Pauxberger made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Not A Defect [ 7 ]
            paux Stephan Pauxberger made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 147110 ] JNJira + In-Review [ 206321 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                paux Stephan Pauxberger
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: