Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16303

“Console Output” context menu item missing for builds with long logs

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      After creating a new job, the "Console" link is missing from the pop-up menu when hovering over a build id on the dashboard page (see attached image).

      https://groups.google.com/forum/?fromgroups=#!topic/jenkinsci-users/w4b9W-KflPQ

      The job is a free form and all it does is ssh into a remote system, grab some data, and echo it so Jenkins can archive the results. I've attached the config.xml.

      The console output does exist in Jenkins filesystem and if you click on a particular build id, the console output link is shown in the top left navigation area.

        Attachments

          Issue Links

            Activity

            toddgreer Todd Greer added a comment -

            I also see this reasonably frequently in 1.483 on Mac OSX viewed on Windows in Firefox. I think it corresponds to when the log is long enough to get abbreviated (with the "Skipping x,xxx KB.. Full log" note and link).

            dhs Dirk Heinrichs added a comment -

            Same here. It's missing only for some jobs while it's there for others. Jenkins version is 1.501.

            jglick Jesse Glick added a comment -

            AbstractBuild/tasks.jelly does not use a standard l:task for logs over 200Kb, so the context menu autogeneration code misses it.

            evernat evernat added a comment -

            duplicate of JENKINS-14264


              People

              • Assignee:
                Unassigned
                Reporter:
                ryanshoemaker ryan shoemaker
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: