Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16557

Git changes reported if in "excluded regions"

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Centos 6.2, Jenkins 1.492, Git plugin 1.126, git 1.7.5.GIT
    • Similar Issues:

      Description

      This has been discussed for subversion plugin and probably others too. But not seen an issue for the git plugin.

      Add a path to the excluded regions section of the plugin. Make a change inside the excluded region. Kick off a build manually.

      The change in the excluded region is listed for this build.

      Not a build is not kicked off by this change - the polling honours the excluded region. It's just the changeset reported that's the problem. And hence the confusion.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          I think the git plugin has the correct behavior in this case. I think the exclusion is intended to prevent polling causing the job to execute when a change is made in a revision which is excluded.

          I don't think the submission should be hidden from the user by not being included in the change list, since the change will be applied to the working copy and will be visible in the file system.

          markewaite Mark Waite added a comment -

          I've resolved this as "Won't fix".

          The original submitter has not commented on the note that this is the expected behavior of the git plugin. It has been 9 months since there was any activity on this bug report.

          markewaite Mark Waite added a comment -

          Closed because this is the expected behavior of the git plugin and the requested behavior (ignore an entire commit if it includes a change in an excluded region) is non-trivial to implement.

          For example, if the commit includes both changes in the excluded region, and changes elsewhere, should it be excluded or included?

          If the change to the excluded region is not included, how will a user ever repeat that build outside Jenkins? It would somehow be assembled from a collection of submissions which does not exist as a graph represented anywhere in the git repository.


            People

            • Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              banoss banoss
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: