Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: performance-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 12.04, Tomcat7, oracle-java7, Jenkins v1.496, Perfomance-plugin 1.8, Standard maven project
    • Similar Issues:

      Description

      Perfomance plugin fail to parse Jmeter report.

      The error (I get this in console, after I ran jmeter test):

      Performance: Failed to parse /opt/jenkins/jobs/stress_testing/builds/2013-02-04_16-39-28/performance-reports/JMeter/scenario_01.jtl Content is not allowed in prolog.

      I saw a similar error relationed with jUnit reports it was solved in 1.7 version. "https://issues.jenkins-ci.org/browse/JENKINS-9655"

        Attachments

          Activity

          serialsito Enrique Jiménez created issue -
          rboon Reinier Boon added a comment -

          I had a similar issue. I was using Jmeter-2.9 so i downgraded Jmeter to an older version. I have now Jmeter-2.6 and that solved the issue for me.

          cappuccino Simon Gamma added a comment - - edited

          Same here. Tested with JMeter 2.9 and JMeter 2.8. The problem seems to be, that newer jmeter versions output a csv file format into jtl (which the plugin doesn't seem to understand).
          You can change the output format to xml by using the following property (as property in ant-task or as value in jmeter.properties:

          jmeter.save.saveservice.output_format=xml
          

          It then works for me.

          johnmurray_io John Murray added a comment -

          Reinier Boon or Simon Gamma, could you please provide a sample file that can be used to reproduce?

          cappuccino Simon Gamma added a comment -

          See the File EXAMPLE-OUTPUT.jtl

          cappuccino Simon Gamma made changes -
          Field Original Value New Value
          Attachment EXAMPLE-OUTPUT.jtl [ 25334 ]
          koutsoulis_philippe Philippe Koutsoulis added a comment -

          Could you try with xml output format?

          cappuccino Simon Gamma added a comment -

          yes - as I've written above, when I force the output to xml this works. Maybe this is just something that should be added to the documentation, since the default output obviously changed between jmeter versions

          guusdk Guus der Kinderen added a comment -

          A fix for this issue is provided in pull request #45: https://github.com/jenkinsci/performance-plugin/pull/45

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Guus der Kinderen
          Path:
          src/main/java/hudson/plugins/performance/AbstractParser.java
          src/main/java/hudson/plugins/performance/IagoParser.java
          src/main/java/hudson/plugins/performance/JMeterCsvParser.java
          src/main/java/hudson/plugins/performance/JMeterParser.java
          src/main/java/hudson/plugins/performance/JUnitParser.java
          src/main/java/hudson/plugins/performance/JmeterSummarizerParser.java
          src/main/java/hudson/plugins/performance/WrkSummarizerParser.java
          src/test/java/hudson/plugins/performance/JMeterParserTest.java
          src/test/resources/JENKINS-16627_CSV_instead_of_XML.jtl
          src/test/resources/emptyfile.jtl
          src/test/resources/whitespace-followed-by-xml.jtl
          http://jenkins-ci.org/commit/performance-plugin/7e1559fc45ed4bea5cadbfd9eae7aaa5b30e0f5a
          Log:
          [FIXED JENKINS-26988]

          At some point in the release history, JMeter switched from XML to CSV as
          a default for data persistency. The performance plugin should determine
          if a JTL file is either XML or CSV, and parse the data accordingly. See
          https://issues.jenkins-ci.org/browse/JENKINS-16627 for more details.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Manuel Carrasco Moñino
          Path:
          .gitignore
          src/main/java/hudson/plugins/performance/AbstractParser.java
          src/main/java/hudson/plugins/performance/AbstractReport.java
          src/main/java/hudson/plugins/performance/IagoParser.java
          src/main/java/hudson/plugins/performance/JMeterCsvParser.java
          src/main/java/hudson/plugins/performance/JMeterParser.java
          src/main/java/hudson/plugins/performance/JUnitParser.java
          src/main/java/hudson/plugins/performance/JmeterSummarizerParser.java
          src/main/java/hudson/plugins/performance/PerformanceProjectAction.java
          src/main/java/hudson/plugins/performance/PerformanceReport.java
          src/main/java/hudson/plugins/performance/WrkSummarizerParser.java
          src/test/java/hudson/plugins/performance/JMeterParserTest.java
          src/test/java/hudson/plugins/performance/JUnitParserTest.java
          src/test/java/hudson/plugins/performance/WrkSummarizerParserTest.java
          src/test/resources/JENKINS-16627_CSV_instead_of_XML.jtl
          src/test/resources/TEST-JUnitResults.xml.serialized
          src/test/resources/emptyfile.jtl
          src/test/resources/jUnitIssue5571.xml.serialized
          src/test/resources/whitespace-followed-by-xml.jtl
          http://jenkins-ci.org/commit/performance-plugin/d5d4c8797a0c13a051d010b380a3d6346c1db3d2
          Log:
          Merge pull request #45 from guusdk/master

          [FIXED JENKINS-26988] [FIXED JENKINS-16627][FIXED JENKINS-15736]

          Compare: https://github.com/jenkinsci/performance-plugin/compare/3e0f37953c07...d5d4c8797a0c

          manolo Manuel Carrasco made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 147451 ] JNJira + In-Review [ 192415 ]
          undera Andrey Pokhilko made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              manolo Manuel Carrasco
              Reporter:
              serialsito Enrique Jiménez
            • Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: