Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16694

Config-file-provider does not submit modified file (submit button simply does nothing at all)

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Debian 6, Tomcat 6, JRE 6, Jenkins 1.500, config-file-provider plugin 2.4
    • Similar Issues:

      Description

      I installed the plugin and restarted Jenkins.
      When I want to submit any config file, the submit button does nothing at all.
      No errors shown or logged.
      Tried on two different Jenkins installations, both showing the problem.
      The plugin is simply unuseable.

        Attachments

          Activity

          mkarg Markus KARG created issue -
          domi Dominik Bartholdi added a comment -

          Which Browser?
          Any JavaScript errors in the Browser?

          mkarg Markus KARG added a comment -

          Thanks for picking this up.
          Happens using Internet Explorer 9 on Windows 7 but works well with Safari!
          No JavaScript errors shown by the browser.
          All the rest of Jenkins (all other plugins) run fine.
          Just this button in this single plugin is the problem.

          domi Dominik Bartholdi added a comment -

          unfortunately I currently don't have a windoz/IE at hand, but could you please try to reproduce the issue with 1.503 or higher? There was an issues fixed which only happened in IE: https://issues.jenkins-ci.org/browse/JENKINS-16561

          mkarg Markus KARG added a comment -

          Tried with Jenkins 1.504 + IE9. Still not working.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: imod
          Path:
          src/main/resources/org/jenkinsci/plugins/configfiles/ConfigFilesManagement/edit.jelly
          http://jenkins-ci.org/commit/config-file-provider-plugin/f2e34e708a30f5626c06a926bad4e9d23c9f429e
          Log:
          [FIXED JENKINS-16694] fix form submission in IE


          You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
          For more options, visit https://groups.google.com/groups/opt_out.

          scm_issue_link SCM/JIRA link daemon made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          mkarg Markus KARG added a comment - - edited

          Tried with Jenkins 1.504 + IE10: Submission is working well!

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 147518 ] JNJira + In-Review [ 192456 ]

            People

            • Assignee:
              domi Dominik Bartholdi
              Reporter:
              mkarg Markus KARG
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: