Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16984

Checkstyle-Plugin not installable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: checkstyle-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.503, debian squeeze
    • Similar Issues:

      Description

      Hi,

      I cannot install "Checkstyle-plugin"¹ for time being.

      I select the plugin at /pluginManager/available to be installed. After Donwload+Restarting the plugin is still not installed.

      The Jenkins.log give me:
      Feb 27, 2013 5:40:15 PM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Loading plugin checkstyle
      hudson.util.IOException2: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:371)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:883)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.NoClassDefFoundError: org/apache/xml/serialize/OutputFormat
      at hudson.plugins.checkstyle.rules.TopicRule.extractNoteContent(TopicRule.java:63)
      at hudson.plugins.checkstyle.rules.TopicRule.end(TopicRule.java:40)
      at org.apache.commons.digester.Rule.end(Rule.java:257)
      at org.apache.commons.digester.Digester.endElement(Digester.java:1345)
      at org.apache.commons.digester.NodeCreateRule$NodeBuilder.endElement(NodeCreateRule.java:236)
      at org.apache.commons.digester.Digester.endElement(Digester.java:1279)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:606)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1742)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2900)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:607)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:489)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:835)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
      at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:123)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1210)
      at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:568)
      at org.apache.commons.digester.Digester.parse(Digester.java:1916)
      at hudson.plugins.checkstyle.rules.CheckStyleRules.initialize(CheckStyleRules.java:60)
      at hudson.plugins.checkstyle.CheckStylePlugin.start(CheckStylePlugin.java:14)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
      ... 9 more
      Caused by: java.lang.ClassNotFoundException: org.apache.xml.serialize.OutputFormat
      at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      ... 30 more

      ¹ https://wiki.jenkins-ci.org/display/JENKINS/Checkstyle+Plugin

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Which Java version? Is this the first time that you installed the plug-in?

            bolbat Alexandr Bolbat added a comment -

            Hello
            The same on my server on 1.503 build

            Java version:
            java version "1.6.0_41"
            Java(TM) SE Runtime Environment (build 1.6.0_41-b02-445-11M4107)
            Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-445, mixed mode)

            Also when i'm opening Plugins management page on installed plugins tab - i don't see installed Checkstyle plugin and when i try to install it again from available plugins tab - after installation and restart nothing changed.

            bolbat Alexandr Bolbat added a comment -

            the same on Java:
            java version "1.7.0_15"
            Java(TM) SE Runtime Environment (build 1.7.0_15-b03)
            Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

            drulli Ulli Hafner added a comment -

            Seems that this is caused by Jenkins 1.503. I just upgraded from 1.501 and now I also get this error. Maybe Jenkins changed the Xerces dependency.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            pom.xml
            http://jenkins-ci.org/commit/checkstyle-plugin/a2f29613dc94b8cd5e5ab6f2cf4769bbfdb1489d
            Log:
            [FIXED JENKINS-16984] Added dependency to xerces.


            You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
            For more options, visit https://groups.google.com/groups/opt_out.

            drulli Ulli Hafner added a comment -

            Please download release 3.34 and retry.

            schultemarkus Markus Schulte added a comment -

            I confirm, Bug is resolved.


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                schultemarkus Markus Schulte
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: