Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17021

Latest plugin version crashes with NPE

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 10.04 LTS x86 - Tomcat 6 - Oracle JVM
    • Similar Issues:

      Description

      Evver since upgrading the plugin to the latest version, all my projects (all using Jenkin's built-in Maven2 builder, haven't tried with other types of projects) fail with the following stacktrace.

      [JENKINS] Archiving redacted
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.NullPointerException
      at java.util.regex.Matcher.getTextLength(Matcher.java:1140)
      at java.util.regex.Matcher.reset(Matcher.java:291)
      at java.util.regex.Matcher.<init>(Matcher.java:211)
      at java.util.regex.Pattern.matcher(Pattern.java:888)
      at hudson.FilePath.normalize(FilePath.java:248)
      at hudson.FilePath.<init>(FilePath.java:194)
      at hudson.plugins.findbugs.FindBugsReporter.getOutputPath(FindBugsReporter.java:180)
      at hudson.plugins.findbugs.FindBugsReporter.perform(FindBugsReporter.java:175)
      at hudson.plugins.analysis.core.HealthAwareReporter.postExecute(HealthAwareReporter.java:313)
      at hudson.maven.Maven2Builder.postExecute(Maven2Builder.java:155)
      at hudson.maven.MavenBuilder$Adapter.postExecute(MavenBuilder.java:310)
      at hudson.maven.agent.PluginManagerInterceptor$1MojoIntercepterImpl.callPost(PluginManagerInterceptor.java:170)
      at hudson.maven.agent.PluginManagerInterceptor.executeMojo(PluginManagerInterceptor.java:183)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:65)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:185)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:151)
      at hudson.maven.Maven2Builder.call(Maven2Builder.java:77)
      at hudson.maven.Maven2Builder.call(Maven2Builder.java:53)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)

      The problem happens on both Jenkins 1.480.2 and 1.480.3.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Ulli Hafner
          Path:
          plugin/src/main/java/hudson/plugins/findbugs/FindBugsReporter.java
          http://jenkins-ci.org/commit/findbugs-plugin/b6ac165cd9cbb2d942ff8fcab250149c0ce1140e
          Log:
          [FIXED JENKINS-17021] Fixed NPE during guessing of result file path.


          You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
          For more options, visit https://groups.google.com/groups/opt_out.

          jsotuyod Juan Sotuyo added a comment -

          I confirm the issue is fixed in the latest plugin build.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              jsotuyod Juan Sotuyo
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: