Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17351

Archiving artifacts does not work at all

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: core
    • Environment:
      Both Jenkins Master and Slave run on virtual machines (VMWare) with Windows XP SP3, Java SDK 1.6.42; on the Master, Jenkins runs as a service, on the slave in the context of an administrative user.
    • Similar Issues:

      Description

      On the slave machine, the installation of a setup package is done via command line ("Windows batch command"). The installation is logged to C:\Freigabe\Installation\LOGS\LicenseServerSetup.log.
      The installation starts the freshly installed servcie. That service creates a log file: C:\Freigabe\Installation\LOGS\LicenseServerServiceTrace.log
      Both files do exist.
      I want to archive the files instead of TYPE them to the console (that is a very bad workaround!).
      In the section "Archive the artifacts", I entered C:\Freigabe\Installation\LOGS\License*.log
      Jenkins insists that the files do not exist, "even C: does not exist" - obviously wrong. Consequently, no artifacts are archived at all.

        Attachments

          Activity

          albers Harald Albers added a comment -

          This is not a bug, see comment.
          The help message has been updated to state that artifacts outside the workspace cannot be archived.

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #2443
          JENKINS-17351 clarified help text (Revision 433e0bfea0b632f341a5b84cf87342d566fe2012)

          Result = SUCCESS
          github : 433e0bfea0b632f341a5b84cf87342d566fe2012
          Files :

          • core/src/main/resources/hudson/tasks/ArtifactArchiver/help-artifacts_de.html
          • core/src/main/resources/hudson/tasks/ArtifactArchiver/help-artifacts.html
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Olivier Lamy
          Path:
          core/src/main/resources/hudson/tasks/ArtifactArchiver/help-artifacts.html
          core/src/main/resources/hudson/tasks/ArtifactArchiver/help-artifacts_de.html
          http://jenkins-ci.org/commit/jenkins/b99a794c6ed28507e4515e68e9c356dff3e6fd76
          Log:
          Merge pull request #756 from albers/JENKINS-17351

          JENKINS-17351 won't fix - clarified help text
          Thanks !

          Compare: https://github.com/jenkinsci/jenkins/compare/77a0d6c5bafc...b99a794c6ed2

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Harald Albers
          Path:
          core/src/main/resources/hudson/tasks/ArtifactArchiver/help-artifacts.html
          core/src/main/resources/hudson/tasks/ArtifactArchiver/help-artifacts_de.html
          http://jenkins-ci.org/commit/jenkins/433e0bfea0b632f341a5b84cf87342d566fe2012
          Log:
          JENKINS-17351 clarified help text

          albers Harald Albers added a comment -

          The archive artifacts feature expects the build artifacts to reside in the workspace.
          When searching for matching artifacts, it recursively scans the workspace and its subdirectories.

          The actual work is delegated to the Ant DirectoryScanner, which will not break out of the parent directory (the workspace in our case).

          See Jenkins help message:

          See the @includes of Ant fileset for the exact format. The base directory is the workspace.

          and Ant documentation:

          In general, patterns are considered relative paths, relative to a task dependent base directory (the dir attribute in the case of <fileset>). Only files found below that base directory are considered. So while a pattern like ../foo.java is possible, it will not match anything when applied since the base directory's parent is never scanned for files.

          To solve your particular problem, I would recommend you redirect your tool's output to a file in the job's workspace and configure archiving for that file.

          albers Harald Albers added a comment -

          There seems to be no support for absolute file paths on Windows file systems.
          Thus, a path like c:\... is treated as a relative path starting with c:


            People

            • Assignee:
              albers Harald Albers
              Reporter:
              bernhard_hiller Bernhard Hiller
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: