Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17436

Artifacts are deployed locally on slaves

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Labels:
      None
    • Environment:
      Master:
      Jenkins @1.506
      Artifactdeployer @ 0.26
      Windows 7
      Slave:
      Windows 7
    • Similar Issues:

      Description

      In our system we have one master and one performance slave.

      • The master server run most jobs
      • The slave run all time critical jobs that require a dedicated system.
        Once a build is done, artifacts is copied to a storage disk on the master server once a build is done.
        This is done to reduce the size of the Jenkins installation on the primary disk. The Artifactdeployer plugin does a great job, and we get the expected behaviour from all the builds that are executed on the master server.
        However we get an unexpected behaviour for builds that are executed on the slave server. The artifacts are deployed relative the slave's system. So if we specify 'D:/artifacts/', then artifacts are copied to the slave's D: disk and not the D: disk on the master.

      We think this is incorrect behaviour since it is now always known on what slave a build will be executed and best practice would be to always deploy artifacts from the masters perspective.

        Attachments

          Activity

          chris_heller chris heller added a comment -

          Just got hit with this as well, except we have a Unix master and some Windows jobs that run on slaves. The master shows the URL with the path name as it is stored on the slave, but clicking the link just triggers a 404 error since the master does not know how to access the file.

          gbois Gregory Boissinot added a comment -

          It is an expected behaviour.
          For now, artifactdeployer plugin is only able to deploy/copy artefacts from workspace to a remote shared filesystem location.
          The artefacts are copied from the build machine (slave).

          Use a shared directory between Linux and Windows.

          manuel4y Manuel added a comment -

          And how do this, when master is a linux and the build-slave is a windows machine?


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              jons Jon Sten
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: