Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17540

ConversionException reading build.xml

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: cppcheck-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.510
      Cppcheck plugin 1.13
    • Similar Issues:

      Description

      It seems every time a build with cppcheck results is loaded, an exception following the pattern of the attached stacktrace is logged.

      Also attached is a snippet of build.xml around the line indicated.

        Attachments

          Activity

          jameshowe James Howe added a comment -

          It appears this also has the effect of making all such builds unloadable, as they've all disappeared on restarting Jenkins. Builds from before I added cppcheck publishing are still present.

          m_broida m_broida added a comment -

          We hit the problem with CppCheck a little while ago.
          Jenkins 1.509.2 (or .4 : not sure if it was after the update).

          We stopped using that plugin and the exceptions disappeared.
          But now we have the problem with build history disappearing and NEW builds not creating "build.xml" files.

          mixalturek Michal Turek added a comment - - edited

          I would like to fix the issue, but I am not unfortunately able to reproduce it. I tried on Debian GNU Linux, Jessie:

          Development run

          • Latest plugin version compiled from sources and executed using "mvn hpi:run", Jenkins 1.447.

          Classic

          • Jenkins 1.510 executed using "export JENKINS_HOME=home && java -jar jenkins.war".
          • Cppcheck plugin 1.14 installed using update center.
          • I checked differences between 1.13 and 1.14 and they are identical in this area.

          Part of build.xml in build_xml_snippet.txt is correct. The issue source in stacktrace.txt is:

          Caused by: com.thoughtworks.xstream.mapper.CannotResolveClassException: com.thalesgroup.hudson.plugins.cppcheck.model.CppcheckWorkspaceFile

          This class is part of the plugin, maybe broken installation? Or it can be somehow related to class loader, class in a different package and http://stackoverflow.com/questions/10438124/xstream-cannotresolveclassexception.

          Questions:

          • Anything that indicates broken plugin installation?
          • Can you provide output of "find home -name CppcheckWorkspaceFile.class" from jenkins home directory? It should be "home/plugins/cppcheck/WEB-INF/classes/com/thalesgroup/hudson/plugins/cppcheck/model/CppcheckWorkspaceFile.class"
          • Is it a new plugin installation or upgrade? From which version?
          • Linux or Windows? Anything specific in configuration?
          • Can you reproduce the issue and optionally provide full jenkins home directory?
          • Anything other?
          jameshowe James Howe added a comment -

          Maybe it's due to JENKINS-12124

          mixalturek Michal Turek added a comment -

          Impossible to reproduce, probably fixed by JENKINS-12124.


            People

            • Assignee:
              mixalturek Michal Turek
              Reporter:
              jameshowe James Howe
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: