Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17684

Dashboard web pages don't render correctly in Chrome because of bad cache/session

    Details

    • Type: Bug
    • Status: Reopened (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      After using Chrome for a day, the page renders incorrectly.

      Screenshot: http://imgur.com/9Y11bqz

      It doesn't matter if I hit refresh multiple times, it always renders the same way. If I open another browser, it works fine.

      If I debug under Chrome Dev Tools, I don't see any errors when fetching the resources... just a whole bunch of 304s.

      If I clear the cache manually using the Chrome Web settings, then everything works fine again.

      I went to #jenkins on freenode and apparently other people were having the same issue.

      *Update* I can make the error go away by simply clearing the jenkins cookie and leaving the rest of the cache intact. It seems the error is session related (all the cookie contains is a session id).

      I am using the GitHub plugin for authentication/authorization.

        Attachments

        1. css_issue
          238 kB
        2. css_issue.jpg
          css_issue.jpg
          238 kB
        3. jenkins_broken_stylesheet.png
          jenkins_broken_stylesheet.png
          129 kB
        4. jenkins_css_3.PNG
          jenkins_css_3.PNG
          84 kB
        5. jenkins-chrome-scroll.JPG
          jenkins-chrome-scroll.JPG
          104 kB
        6. jenkins-gui.png
          jenkins-gui.png
          69 kB

          Issue Links

            Activity

            rburhum Ragi Burhum created issue -
            rburhum Ragi Burhum made changes -
            Field Original Value New Value
            Summary Dashboard web pages don't render correctly in Chrome because of bad cache Dashboard web pages don't render correctly in Chrome because of bad cache/session
            Description After using Chrome for a day, the page renders incorrectly.

            Screenshot: http://imgur.com/9Y11bqz

            It doesn't matter if I hit refresh multiple times, it always renders the same way. If I open another browser, it works fine.

            If I debug under Chrome Dev Tools, I don't see any errors when fetching the resources... just a whole bunch of 304s.

            If I clear the cache manually using the Chrome Web settings, then everything works fine again.

            I went to #jenkins on freenode and apparently other people were having the same issue.
            After using Chrome for a day, the page renders incorrectly.

            Screenshot: http://imgur.com/9Y11bqz

            It doesn't matter if I hit refresh multiple times, it always renders the same way. If I open another browser, it works fine.

            If I debug under Chrome Dev Tools, I don't see any errors when fetching the resources... just a whole bunch of 304s.

            If I clear the cache manually using the Chrome Web settings, then everything works fine again.

            I went to #jenkins on freenode and apparently other people were having the same issue.

            **Update** I can make the error go away by simply clearing the jenkins cookie and leaving the rest of the cache intact. It seems the error is session related (all the cookie contains is a session id).

            I am using the GitHub plugin for authentication/authorization.
            nacht Pedro Rodriguez made changes -
            Link This issue is duplicated by JENKINS-17526 [ JENKINS-17526 ]
            outspoken Ken Garland made changes -
            Attachment css_issue [ 23641 ]
            outspoken Ken Garland made changes -
            Attachment css_issue.jpg [ 23642 ]
            outspoken Ken Garland made changes -
            Assignee Account App Run by Kohsuke [ accountapp ]
            vladichko Vlad Aginsky made changes -
            Attachment jenkins-gui.png [ 23667 ]
            kevinhcross Kevin Cross made changes -
            Attachment jenkins_css_3.PNG [ 23669 ]
            cwozny Chris Wozny made changes -
            Attachment jenkins_broken_stylesheet.png [ 23684 ]
            scm_issue_link SCM/JIRA link daemon made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            kerrhome Shannon Kerr made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            orrc Christopher Orr made changes -
            Status Reopened [ 4 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            lacostej lacostej made changes -
            Resolution Fixed [ 1 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            lacostej lacostej made changes -
            Labels lts-candidate
            lacostej lacostej made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            jglick Jesse Glick made changes -
            Labels lts-candidate 1.509.2-fixed
            srinivav Srinivasan Venkataraman made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            srinivav Srinivasan Venkataraman made changes -
            Attachment jenkins-chrome-scroll.JPG [ 33366 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 148864 ] JNJira + In-Review [ 186122 ]

              People

              • Assignee:
                accountapp Account App Run by Kohsuke
                Reporter:
                rburhum Ragi Burhum
              • Votes:
                24 Vote for this issue
                Watchers:
                45 Start watching this issue

                Dates

                • Created:
                  Updated: