Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17715

Display Name is not shown

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      After upgrade from 1.510 to 1.512 'Display Name' that is set within a job
      is not shown anymore. Just the Project name.

        Attachments

          Issue Links

            Activity

            mihalich Joe Mihalich added a comment - - edited

            I am seeing this too. The display name does not show in the view tabs, only the project name. If you click on the project to drill into it, it does show the display name on the job page. I upgraded from 502 to 512 this morning.

            barnett2 Dave Barnett added a comment -

            I see the same behavior after an upgrade to 1.512.

            hameno Philip Schiffer added a comment -

            Same behaviour here too with 1.512

            vlatombe Vincent Latombe added a comment -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: ssogabe
            Path:
            changelog.html
            core/src/main/java/hudson/Functions.java
            core/src/main/java/hudson/model/AbstractItem.java
            core/src/test/java/hudson/FunctionsTest.java
            http://jenkins-ci.org/commit/jenkins/55a68acca970dca12dcde6028b56a784d0c7c5fa
            Log:
            [FIXED JENKINS-17715] Display Name is not shown

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2498
            [FIXED JENKINS-17715] Display Name is not shown (Revision 55a68acca970dca12dcde6028b56a784d0c7c5fa)

            Result = SUCCESS
            s.sogabe : 55a68acca970dca12dcde6028b56a784d0c7c5fa
            Files :

            • core/src/main/java/hudson/model/AbstractItem.java
            • changelog.html
            • core/src/main/java/hudson/Functions.java
            • core/src/test/java/hudson/FunctionsTest.java
            bcoveny Bruce Coveny added a comment - - edited

            This states resolved but we are on version 1.514 and are still seeing the Job Name being shown in the tabs on the main screen and not the Job Display Name.

            sogabe sogabe added a comment -

            This is fixed in 1.515. see changelog.

            danielbeck Daniel Beck added a comment -

            Is this broken in 1.509.x as well, or why is it labeled lts-candidate?

            ctapobep Stanislav Bashkyrtsev added a comment -

            sogabe, the fix you've introduced is a reason of Jenkins overall performance downgrade. Please see JENKINS-18723 Would be great if another way of the bug fix was introduced.

            mkebaypl2 Marcin Krol added a comment -

            I still have this issue in 1.531 (platform: Ubuntu 12.04.3 LTS)

            java -version
            java version "1.6.0_27"
            OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1ubuntu0.12.04.2)
            OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

            danielbeck Daniel Beck added a comment -

            Marcin: I just set up a new Jenkins instance with 1.531 and the default 'All' list view shows the display name of a freestyle job I just created. Could you be more specific about the circumstances you're experiencing this issue in, maybe even provide steps to reproduce the problem on a Jenkins instance created from scratch?

            mkebaypl2 Marcin Krol added a comment -

            Thanks for reply, Daniel!

            I have done some more testing and this problem seems to be specific to latest Firefox (24.0, running on Windows 8). FF is in Polish language version (Windows 8 has US locale). That is, when I log into Jenkins using Chrome, the project name stays as it should be.

            My colleagues are running FF on various Linux distros and they have the same problem, so it seems FF-specific and perhaps it is created by server locale as well:

            The server is Ubuntu Server 12.04, Polish locale set:

            LANG=pl_PL.UTF-8
            LANGUAGE=
            LC_CTYPE="pl_PL.UTF-8"
            LC_NUMERIC="pl_PL.UTF-8"
            LC_TIME="pl_PL.UTF-8"
            LC_COLLATE="pl_PL.UTF-8"
            LC_MONETARY="pl_PL.UTF-8"
            LC_MESSAGES="pl_PL.UTF-8"
            LC_PAPER="pl_PL.UTF-8"
            LC_NAME="pl_PL.UTF-8"
            LC_ADDRESS="pl_PL.UTF-8"
            LC_TELEPHONE="pl_PL.UTF-8"
            LC_MEASUREMENT="pl_PL.UTF-8"
            LC_IDENTIFICATION="pl_PL.UTF-8"
            LC_ALL=

            What's really strange is that some parts of the interface are localized and some parts are not localized:

            http://s16.postimg.org/74fstcymt/jenkins_locale.png

            If you need any testing, tweaking or changes, let me know, I'll help out.

            mkebaypl2 Marcin Krol added a comment -

            P.S. of course I should have written that this happens when I click project config after logging in.

            vlatombe Vincent Latombe added a comment -

            @Marcin : it's definitely a different issue, I'd recommend that you open a separate jira for this.

            mkebaypl2 Marcin Krol added a comment -

            It's a bug in KeeFox (FF extension). Apparently it thinks that "Project Name" is a password field and it autofills it.

            After disabling KeeFox in FF the Project Name is filled correctly (that is, it contains actual project name and there are no issues on clicking Save button in project configuration).


              People

              • Assignee:
                Unassigned
                Reporter:
                emwfrpr emwfrpr
              • Votes:
                3 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: