Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17733

$DEFAULT_RECIPIENTS is the default Project Reply-To List instead of $DEFAULT_REPLYTO

    Details

    • Similar Issues:

      Description

      When adding "Editable Email Notification" as a post-build action, I am seeing that $DEFAULT_RECIPIENTS is always set in the Project Reply-To List field by default, instead of $DEFAULT_REPLYTO. All the other fields have their $DEFAULT_xxx variables matching their corresponding field, but it looks like there may have been a copy/paste oversight and the wrong default variable is being used for the Reply-To field.

      See screenshot: http://i.imgur.com/Ckq1UHl.png

      I've tested a fix for this and will submit the diff in a Pull Request on the GitHub project for email-ext.

        Attachments

          Activity

          stmontgomery Stuart Montgomery created issue -
          stmontgomery Stuart Montgomery made changes -
          Field Original Value New Value
          Assignee Stuart Montgomery [ stmontgomery ] Alex Earl [ slide_o_mix ]
          stmontgomery Stuart Montgomery made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          stmontgomery Stuart Montgomery made changes -
          Description When adding "Editable Email Notification" as a post-build action, I am seeing that $DEFAULT_RECIPIENTS is always set in the Project Reply-To List field by default, instead of $DEFAULT_REPLYTO. All the other fields have their $DEFAULT_xxx variables matching their corresponding field, but it looks like there may have been a copy/paste oversight and the wrong default variable is being used for the Reply-To field.

          I've tested a fix for this and will submit the diff in a Pull Request on the GitHub project for email-ext.
          When adding "Editable Email Notification" as a post-build action, I am seeing that $DEFAULT_RECIPIENTS is always set in the Project Reply-To List field by default, instead of $DEFAULT_REPLYTO. All the other fields have their $DEFAULT_xxx variables matching their corresponding field, but it looks like there may have been a copy/paste oversight and the wrong default variable is being used for the Reply-To field.

          See screenshot: http://i.imgur.com/Ckq1UHl.png

          I've tested a fix for this and will submit the diff in a Pull Request on the GitHub project for email-ext.
          slide_o_mix Alex Earl made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 148913 ] JNJira + In-Review [ 192938 ]

            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              stmontgomery Stuart Montgomery
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: